hust 1602, 乱搞

D - Substring
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

This problem is quiet easy.
Initially, there is a string A.
 
Then we do the following process infinity times.
 A := A + “HUSTACM” + A
 
For example, if a = “X”, then
After 1 step, A will become “XHUSTACMX”
After 2 steps, A will become “XHUSTACMXHUSTACMXHUSTACMX”
 
Let A = “X”, Now I want to know the characters from L to R of the final string.

Input

Multiple test cases, in each test case, there are only one line containing two numbers L and R.
1 <= L <= R <= 10^12
R-L <= 100

Output

For each test case, you should output exactly one line which containing the substring.

Sample Input

5 10

Sample Output

TACMXH
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<vector>
#include<cstdlib>
#include<algorithm>

using namespace std;

#define LL long long
#define ULL unsigned long long
#define UINT unsigned int
#define MAX_INT 0x7fffffff
#define MAX_LL 0x7fffffffffffffff
#define MAX(X,Y) ((X) > (Y) ? (X) : (Y))
#define MIN(X,Y) ((X) < (Y) ? (X) : (Y))

int main(){
//  fstream fin("C:\\Users\\Administrator\\Desktop\\in.txt",ios::in);

    const char s[]="XHUSTACM";
    LL l,r;
    while(cin>>l>>r){
        LL i=0,len=strlen(s);
        LL j=(l-1)%len;
        for(i=0; i<r-l+1; i++){
            printf("%c",s[j]);
            j=(j+1)%len;
        }
        printf("\n");
    }

//  fin.close();
    return 0;
}

 

转载于:https://www.cnblogs.com/ramanujan/p/3413025.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值