hdu-4451-Dressing

/*

第4场多校联合训练解题报告——详见杭电ACM微博~
Dressing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1574    Accepted Submission(s): 670


Problem Description
Wangpeng has N clothes, M pants and K shoes so theoretically he can have N×M×K different combinations of dressing.
One day he wears his pants Nike, shoes Adiwang to go to school happily. When he opens the door, his mom asks him to come back and switch the dressing. Mom thinks that pants-shoes pair is disharmonious because Adiwang is much better than Nike. After being asked to switch again and again Wangpeng figure out all the pairs mom thinks disharmonious. They can be only clothes-pants pairs or pants-shoes pairs.
Please calculate the number of different combinations of dressing under mom’s restriction.
 

Input
There are multiple test cases.
For each case, the first line contains 3 integers N,M,K(1≤N,M,K≤1000) indicating the number of clothes, pants and shoes.
Second line contains only one integer P(0≤P≤2000000) indicating the number of pairs which mom thinks disharmonious.
Next P lines each line will be one of the two forms“clothes x pants y” or “pants y shoes z”.
The first form indicates pair of x-th clothes and y-th pants is disharmonious(1≤x≤N,1 ≤y≤M), and second form indicates pair of y-th pants and z-th shoes is disharmonious(1≤y≤M,1≤z≤K).
Input ends with “0 0 0”.
It is guaranteed that all the pairs are different.
 

Output
For each case, output the answer in one line.
 

Sample Input
2 2 2
0
2 2 2
1
clothes 1 pants 1
2 2 2
2
clothes 1 pants 1
pants 1 shoes 1
0 0 0
 

Sample Output
8
6
5
 

Source
2012 Asia JinHua Regional Contest


题意:略。

思路:
简单的组合问题,注意加上重复的就是(在一个点上左边的线乘以右边的线的个数)
*/
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<stdio.h>
#include<stdlib.h>
#include<math.h>
#include<string.h>
using namespace std;
#define maxn 1100
int cpn[maxn],psk[maxn];
int main()
{
   int sum,i,p,a,b,n,m,k,tmp;
   char s[15];
   while(scanf("%d%d%d",&n,&m,&k),n||m||k)
   {
       memset(cpn,0,sizeof(cpn));
       memset(psk,0,sizeof(psk));
       scanf("%d",&p);
       sum=n*m*k;
       tmp=0;
       for(i=0;i<p;i++)
       {
           scanf("%s%d%s%d",s,&a,s,&b);
           if(strcmp(s,"pants")==0)
           {
               cpn[b-1]++;
               tmp+=k;
           }
           else
           {
               psk[a-1]++;
               tmp+=n;
           }
       }
       for(i=0;i<m;i++)
       {
           tmp-=cpn[i]*psk[i];
       }
       printf("%d\n",sum-tmp);
   }
    return 0;
}

 

转载于:https://www.cnblogs.com/heqinghui/p/3234622.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值