1014. Waiting in Line (30)——PAT (Advanced Level) Practise

题目信息:

1014. Waiting in Line (30)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer[i] will take T[i] minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.

At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output "Sorry" instead.

Sample Input
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output
08:07
08:06
08:10
17:00
Sorry


代码如下:

#include <stdio.h>
#include <memory.h>
#include <iostream>
#include <queue>
using namespace std;
struct tagque
{
	int que_time, loc;
};
tagque tque;
queue<tagque> que[21];
int process_time[1001];//每个客户的时间
int que_time[21];//每个队列当前时间
int final_time[1001];//每个客户离开时间
int N, M, K, Q;
int que_op() //寻找一人完成业务离开银行
{
	int i, min = 1;
	while (min < N && que[min].empty())
		++min;
	for (i = min + 1; i <= N; ++i)
	{
		if (que[i].size() > 0 && que[i].front().que_time + que_time[i] < que[min].front().que_time + que_time[min])
		{
			min = i;
		}
	}
	if (que[min].empty())
	{
		return false;
	}
	else
	{
		tque = que[min].front();
		que[min].pop();
		final_time[tque.loc] = que_time[min] + tque.que_time;
		que_time[min] += tque.que_time;
		return true;
	}
}
void insert(int val, int loc)//插入一个客户,索引loc
{
	int i;
	int min = 1;
	for (i = 2; i <= N; ++i)
	{
		if (que[i].size() < M && que[i].size() < que[min].size())
			min = i;
	}

	if (1 == min && que[1].size() == M) //未找到合适位置再处理一人
	{
		que_op();
		insert(val, loc);
	}
	else
	{
		tque.que_time = val;
		tque.loc = loc;
		que[min].push(tque);
	}
}
int main()
{
	//freopen("d:\\1.txt", "r", stdin);
	memset(final_time, 0, sizeof(final_time));
	
	scanf("%d%d%d%d", &N, &M, &K, &Q);
	int i, val;
	for (i = 1; i <= N; ++i)
	{
		que_time[i] = 8 * 60;
	}
	for (i = 1; i <= K; ++i)
	{
		scanf("%d", &val);
		process_time[i] = val;
		insert(val, i);
	}
	while (que_op()) //处理完所有人
		continue;
	for (i = 1; i <= Q; ++i)
	{
		scanf("%d", &val);
		if (final_time[val] - process_time[val] >= 1020) //17*60 = 1020,17:00之后开始的才Sorry!开始!!!
			printf("Sorry\n");
		else
			printf("%02d:%02d\n", final_time[val] / 60, final_time[val] % 60);
	}
	return 0;
}


转载于:https://www.cnblogs.com/xyyh/p/4382635.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值