HDU 1398 Square Coins

母函数简单应用

题目:

Square Coins

Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.
 
Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
 
Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.
 

 

Sample Input
 
  
2
10
30
0
 

 

Sample Output
 
  
1
4
27
代码:
#include<stdio.h>

#define max 310
int main()
{
    int coin[17] = {1,4,9,16,25,36,49,64,81,100,121,144,169,196,225,256,289}; //列出所有coin的面值
    int n,i,j,k, an[max], bn[max]; //an[]记录结果,bn[]记录中间值
    while(scanf("%d", &n) && n)
    {
        for(i = 0; i <= n; i ++) //赋初值
        {
            an[i] = 1;
            bn[i] = 0;
        }
        for(j = 1; j < 17; j ++) //从1到289
        {
            for(i = 0; i <= n; i ++)
            {
                for(k = 0; k + i <= n; k += coin[j])
                    bn[k + i] += an[i];
            }
            for(i = 0; i <= n; i ++)
            {
                an[i] = bn[i];
                bn[i] = 0;
            }
        }
        printf("%d\n", an[n]);
    }
    return 0;
}

转载于:https://www.cnblogs.com/Mr_Lai/archive/2010/11/24/1886462.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值