Time Limit: 2000MS | Memory Limit: 30000K | |
Total Submissions: 16258 | Accepted: 5579 | |
Case Time Limit: 1000MS |
Description
Write a program that can verify the results of the game.
Input
* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.
Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.
Output
Sample Input
6 M 1 6 C 1 M 2 4 M 2 6 C 3 C 4
Sample Output
1 0 2
Source
#include <iostream>
#include<stdio.h>
using namespace std;
#define maxn 30003
int num[maxn];
int dis[maxn]={0};
int father[maxn];
int find_set(int x)
{
if(x!=father[x])
{
int temp=father[x];
father[x]=find_set(father[x]);
dis[x]+=dis[temp];
}
return father[x];
}
void union_set(int a,int b)
{
int fathera=find_set(a);
int fatherb=find_set(b);
father[fatherb]=fathera;
dis[fatherb]=num[fathera];
num[fathera]+=num[fatherb];
}
int main()
{
int n;
char ch[2];
int a,b;
scanf("%d",&n);
int i;
for(i=0;i<maxn;i++)
{
father[i]=i;
num[i]=1;
}
while(n--)
{
scanf("%s%d",&ch,&a);
if(ch[0]=='M')
{
scanf("%d",&b);
union_set(a,b);
}
else
{
int temp=find_set(a);
printf("%d\n",num[temp]-dis[a]-1);
}
}
return 0;
}