B - Toy Storage(POJ - 2398) 计算几何基础题,比TOYS多了个线段排序

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore. 
Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top: 


We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.

Input

The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard. 

A line consisting of a single 0 terminates the input.

Output

For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.

Sample Input

4 10 0 10 100 0

20 20

80 80

60 60

40 40

5 10

15 10

95 10

25 10

65 10

75 10

35 10

45 10

55 10

85 10

5 6 0 10 60 0

4 3

15 30

3 1

6 8

10 10

2 1

2 8

1 5

5 5

40 10

7 9

0

Sample Output

Box

2: 5

Box

1: 4

2: 1


多之前的POJ-2318多了一个线段排序,总体难度不大,计算几何的基础题

#include <iostream>  
#include <cstdio>  
#include <cstring>  
#include <algorithm>  
using namespace std;  
  
struct point  
{  
    int x,y;  
};  
  
struct Line  
{  
    point a,b;  
}line[2010];  
  
int toy[2010];  
int ans[2010];  
  
bool cmp(Line p,Line q)//线段排序,我是跪着看的,虽然很好懂  
{  
    return min(p.a.x,p.b.x)<min(q.a.x,q.b.x)||((min(p.a.x,p.b.x)==min(q.a.x,q.b.x))&&(max(p.a.x,p.b.x)<max(q.a.x,q.b.x)));  
}  
  
int cross(point p0,point p1,point p2)  
{  
    return (p1.x-p0.x)*(p2.y-p0.y)-(p1.y-p0.y)*(p2.x-p0.x);//等同于TOYS的ans判断  
}  
  
void binarysearch(point t,int n)//更喜欢一点这个二分  
{  
    int l=0,r=n-1,mid;  
    while(l<r)  
    {  
        mid=(l+r)>>1;  
        if(cross(t,line[mid].a,line[mid].b)>0)//在右侧  
            l=mid+1;  
        else  
            r=mid;  
    }  
    if(cross(t,line[l].a,line[l].b)<0)//在左侧  
        toy[l]++;  
    else  
        toy[l+1]++;  
}  
  
int main()  
{  
    //freopen("input.txt","r",stdin);
	int n,m,x1,y1,x2,y2;  
    while(scanf("%d",&n),n)  
    {  
        int i,u,l;  
        scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2);  
        for(i=0;i<n;i++)  
        {  
            scanf("%d%d",&u,&l);  
            line[i].a.x=u;  
            line[i].a.y=y1;  
            line[i].b.x=l;  
            line[i].b.y=y2;  
        }  
        sort(line,line+n,cmp);//此处sort为全题重点  
        
		memset(toy,0,sizeof(toy));  
        memset(ans,0,sizeof(ans));  
        
		point t;  
        for(i=0;i<m;i++)  
        {  
            scanf("%d%d",&t.x,&t.y);  
            binarysearch(t,n);  
        }  
        
		for(i=0;i<=n;i++)  
            ans[toy[i]]++;//ans数组对应存数了  
        
		printf("Box\n");  
        for(i=1;i<=m;i++)  
        {  
            if(ans[i])  
            {  
                printf("%d: %d\n", i, ans[i]);  
                m-=i*toy[i];//这一行真的特别优美  
            }  
        }  
    }  
    return 0;  
} 


转载于:https://www.cnblogs.com/pearfl/p/10733198.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值