ACM学习历程——HDU5137 How Many Maos Does the Guanxi Worth(14广州10题)(单源最短路)...

Problem Description
   "Guanxi" is a very important word in Chinese. It kind of means "relationship" or "contact". Guanxi can be based on friendship, but also can be built on money. So Chinese often say "I don't have one mao (0.1 RMB) guanxi with you." or "The guanxi between them is naked money guanxi." It is said that the Chinese society is a guanxi society, so you can see guanxi plays a very important role in many things.
   Here is an example. In many cities in China, the government prohibit the middle school entrance examinations in order to relief studying burden of primary school students. Because there is no clear and strict standard of entrance, someone may make their children enter good middle schools through guanxis. Boss Liu wants to send his kid to a middle school by guanxi this year. So he find out his guanxi net. Boss Liu's guanxi net consists of N people including Boss Liu and the schoolmaster. In this net, two persons who has a guanxi between them can help each other. Because Boss Liu is a big money(In Chinese English, A "big money" means one who has a lot of money) and has little friends, his guanxi net is a naked money guanxi net -- it means that if there is a guanxi between A and B and A helps B, A must get paid. Through his guanxi net, Boss Liu may ask A to help him, then A may ask B for help, and then B may ask C for help ...... If the request finally reaches the schoolmaster, Boss Liu's kid will be accepted by the middle school. Of course, all helpers including the schoolmaster are paid by Boss Liu.
   You hate Boss Liu and you want to undermine Boss Liu's plan. All you can do is to persuade ONE person in Boss Liu's guanxi net to reject any request. This person can be any one, but can't be Boss Liu or the schoolmaster. If you can't make Boss Liu fail, you want Boss Liu to spend as much money as possible. You should figure out that after you have done your best, how much at least must Boss Liu spend to get what he wants. Please note that if you do nothing, Boss Liu will definitely succeed.
 
Input
   There are several test cases.
   For each test case:
   The first line contains two integers N and M. N means that there are N people in Boss Liu's guanxi net. They are numbered from 1 to N. Boss Liu is No. 1 and the schoolmaster is No. N.   M means that there are M guanxis in Boss Liu's guanxi net. (3 <=N <= 30, 3 <= M <= 1000)
   Then M lines follow. Each line contains three integers A, B and C, meaning that there is a guanxi between A and B, and if A asks B or B asks A for help, the helper will be paid C RMB by Boss Liu.
   The input ends with N = 0 and M = 0.
   It's guaranteed that Boss Liu's request can reach the schoolmaster if you do not try to undermine his plan.
 
Output
   For each test case, output the minimum money Boss Liu has to spend after you have done your best. If Boss Liu will fail to send his kid to the middle school, print "Inf" instead.
 
Sample Input
4 5
1 2 3
1 3 7
1 4 50
2 3 4
3 4 2
3 2
1 2 30
2 3 10
0 0
 
Sample Output
50
Inf
 
按照题目的意思,对点进行枚举,并单源最短路搜救可以了。注意判断条件即可。
 
代码:
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <queue>

using namespace std;

int n, m, d[31][31];
int dis[31];
bool vis[31];

void Input()
{
    memset(d, -1, sizeof(d));
    int a, b, c;
    for (int i = 0; i < m; ++i)
    {
        scanf("%d%d%d", &a, &b, &c);
        if (d[a][b] == -1 || d[a][b] > c)
            d[a][b] = d[b][a] = c;
    }
}

int SPFA(int x)
{
    memset(vis, 0, sizeof(vis));
    memset(dis, -1, sizeof(dis));
    dis[1] = 0;
    queue <int> q;
    q.push(1);
    int k;
    while (!q.empty())
    {
        k = q.front();
        q.pop();
        vis[k] = 0;
        for (int i = 2; i <= n; ++i)
        {
            if (d[k][i] == -1 || i == x)
                continue;
            if (dis[i] == -1 || dis[i] > dis[k] + d[k][i])
            {
                dis[i] = dis[k] + d[k][i];
                if (vis[i] == 0)
                {
                    q.push(i);
                    vis[i] = 1;
                }
            }
        }
    }
    return dis[n];
}

int qt()
{
    int ans, v;
    for (int i = 2; i < n; ++i)
    {
        v = SPFA(i);
        if (v == -1)
            return -1;
        if (i == 2)
            ans = v;
        else
            ans = max(ans, v);
    }
    return ans;
}

int main()
{
    //freopen("test.txt", "r", stdin);
    while (scanf("%d%d", &n, &m) != EOF && n && m)
    {
        Input();
        int ans = qt();
        if (ans == -1)
            printf("Inf\n");
        else
            printf("%d\n", ans);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/andyqsmart/p/4162358.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值