Description
Input
Output
Sample Input
5 1 2
2 1
Sample Output
HINT
对于100%的数据,1≤N≤2×105,1<Ai,Bi≤10^5
Source
dp神题,逆推所需,水到渠成;
题目给了很多信息:
1.完全二叉树,那么树高为log,且每个点最多两个儿子;
2.点亮的灯时刻是一个连通块,且必须点亮完其子树内的点才能点亮其他点;
因为第一个点是不确定的,所以我们可以尝试枚举第一个点x,然后开始点灯,因为需要满足点亮的灯时刻是一个连通块并且一定要处理完子树内才能往外走,所以点灯的顺序一定是:
x的子树->x的父亲->x的兄弟的子树->x的爸爸的爸爸...这样一直搞直到根为止;
这个时候我们就会需要一个知道一个g[x][y],表示处理完x的子树后,走到了y节点的代价(其中y为x的祖先),因为树高为log,所以第二维开一个log就可以了,表示深度为y的祖先;
我们考虑如何求g[x][y],如果x是叶子节点,那么直接走过去就好了;
否则的话就有两个选择,先走左子树还是先走右子树,如果是先走左子树的话,点完左子树后,我们需要去点亮x的右儿子,然后把右子树点完,然后从右子树中某点去点x的深度为y的祖先;
这个时候我们还需要求出处理完x的子树后,走到了x的兄弟的代价,这个我们用一个数组f[x][y],表示处理完x的子树后,走到了x的深度为y的兄弟的代价;
因为为完全二叉树,那么x的k级父亲可以直接用位运算算出来,g[x][y]和f[x][y]都能通过合并左右两子树的信息来得到;
最后我们枚举每个点用g数组来模拟覆盖的过程即可;
注意叶子节点和没有右儿子的节点特殊处理一下;
//MADE BY QT666
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
typedef long long ll;
const int N=200050;
ll g[N][20],f[N][20],a[N],b[N],n,dep[N],dis[N];
int main(){
scanf("%lld",&n);dep[1]=1;
for(int i=1;i<=n;i++) scanf("%lld",&a[i]);
for(int i=2;i<=n;i++){
scanf("%lld",&b[i]);
dep[i]=dep[i>>1]+1;dis[i]=dis[i>>1]+b[i];
}
for(int x=n;x;x--){
if((x<<1)>n){
for(int j=0;j<=dep[x];j++){
int fa=(x>>(dep[x]-j+1)),y=((x>>(dep[x]-j))^1);
f[x][j]=(dis[x]+dis[y]-2*dis[fa])*a[y];
}
}
else if((x<<1)==n){
for(int j=0;j<=dep[x];j++){
int y=(x<<1);
f[x][j]=a[y]*b[y]+f[y][j];
}
}
else {
for(int j=0;j<=dep[x];j++){
int lson=(x<<1),rson=(x<<1|1);
f[x][j]=min(a[lson]*b[lson]+f[lson][dep[lson]]+f[rson][j],a[rson]*b[rson]+f[rson][dep[rson]]+f[lson][j]);
}
}
}
for(int x=n;x;x--){
if((x<<1)>n){
for(int j=0;j<=dep[x];j++){
int y=(x>>(dep[x]-j));
g[x][j]=(dis[x]-dis[y])*a[y];
}
}
else if((x<<1)==n){
for(int j=1;j<=dep[x];j++){
int y=(x<<1);
g[x][j]=a[y]*b[y]+g[y][j];
}
}
else{
for(int j=0;j<=dep[x];j++){
int lson=(x<<1),rson=(x<<1|1);
g[x][j]=min(a[lson]*b[lson]+f[lson][dep[lson]]+g[rson][j],a[rson]*b[rson]+f[rson][dep[rson]]+g[lson][j]);
}
}
}
ll ans=g[1][0];
for(int i=2;i<=n;i++){
ll ret=g[i][dep[i]-1];
for(int x=i;x>1;x>>=1){
int y=x^1;
if(y>n) ret+=a[x>>2]*b[x>>1];
else ret+=a[y]*b[y]+g[y][dep[y]-2];
}
ans=min(ans,ret);
}
printf("%lld\n",ans);
return 0;
}