HDU 1159.Common Subsequence-最长公共子序列(LCS)

 

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 39661    Accepted Submission(s): 18228


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
 

 

Sample Input
abcfbc abfcab
programming contest
abcd mnp
 

 

Sample Output
4
2
0
 

 

题意就是求两个字符串的最长公共子序列的长度。

LCS入门,传送门1:http://blog.csdn.net/liufeng_king/article/details/8500084 

              传送门2:http://blog.csdn.net/orbit/article/details/6717125

 

代码:

#include<bits/stdc++.h>
using namespace std;
const int N=1e3+10;
char s1[N],s2[N];
int dp[N][N];
int len1,len2;
void fun(){
    memset(dp,0,sizeof(dp));
    for(int i=1;i<=len1;i++){
        for(int j=1;j<=len2;j++){
            if(s1[i-1]==s2[j-1])
                dp[i][j]=dp[i-1][j-1]+1;
            else
                dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
        }
    }
}
int main(){
   while(~scanf("%s%s",&s1,&s2)){
    len1=strlen(s1);
    len2=strlen(s2);
    fun();
    printf("%d\n",dp[len1][len2]);
   }
   return 0;
}

 

 

 

 

转载于:https://www.cnblogs.com/ZERO-/p/7207653.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值