HDU 3172 Virtual Friends(并查集)

 

 

          Virtual Friends

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1629    Accepted Submission(s): 472


Problem Description
These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends' friends, their friends' friends' friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends.

Your task is to observe the interactions on such a website and keep track of the size of each person's network.

Assume that every friendship is mutual. If Fred is Barney's friend, then Barney is also Fred's friend.
 

 

Input
Input file contains multiple test cases.
The first line of each case indicates the number of test friendship nest.
each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).
 

 

Output
Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.
 

 

Sample Input
1
3
Fred Barney
Barney Betty
Betty Wilma
 

 

Sample Output
2
3
4
 

 

Source
 

 

Recommend
chenrui
 
 
题意:给你两个人,他们刚成为朋友,问在这两个人的社交圈里有多少个朋友?提示:朋友的朋友也是你的朋友。
分析:用字典树解决,注意下面这组数据:
1
6
Fred Barney
Barney Betty
Betty Wilma
AAAAA BBBBB
AAAA  BBBBB
AAAA Fred
输出结果应是:
2
3
4
2
3
7
 
 
#include<iostream>
#include<string>
#include<map>
using namespace std;
#define MAX 100005
int father[MAX],sum[MAX];
int total;
map<string,int>A;//用map来处理人名与数字下标之间的对应关系

int find_set(int x)
{
    if(x!=father[x])
        father[x]=find_set(father[x]);
    return father[x];
}
void union_set(int x,int y)
{
    x=find_set(x);
    y=find_set(y);
    if(x!=y)
    {
        father[x]=y;
        sum[y]+=sum[x];
    }
}

int main()
{
    int t,n;
    string a,b;
    while(scanf("%d",&t)!=EOF)
    {           
        while(t--)
        {        
            total=0;
            A.clear();          
            scanf("%d",&n);
            while(n--)
            {
                cin>>a>>b;
                if(A.find(a)==A.end())  
                {  
                    total++;  
                    A[a]=total;  
                    father[total]=total;  
                    sum[total]=1;  
                    
                }  
                if(A.find(b)==A.end())  
                {  
                    total++;  
                    A[b]=total;  
                    father[total]=total;  
                    sum[total]=1;  
                }  
                union_set(A[a],A[b]);
                int ans=find_set(A[b]);
                printf("%d\n",sum[ans]);
            }        
        }        
    }
    return 0;
}

 

 

转载于:https://www.cnblogs.com/Su-Blog/archive/2012/08/15/2640715.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值