poj3278 Catch That Cow 一维广搜 bfs入门

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 107515 Accepted: 33598

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


题意:

    一个农夫在n位置想追上一头在k位置的牛,每次可以选择3种移动方式

1:左移一格

2:右移一格

3:从x位置移动到x*2位置


现在让求最少的步数

比较简单的一个题

对这三种情况进行广搜即可。

每次对当前位置进行标记防止重复搜索(因为这个MLE了一次...

#include <iostream>
#include <algorithm>
#include <cstdlib>
#include <cstdio>
#include <queue>
#include <cstring>
#define INF 0x3f3f3f3f
#define For(i,n) for(int i=0;i<n;i++)
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
#define maxn 100005
#define move MOVE
typedef struct
{
    int x,step;        //每一个位置的步数和坐标x
} cow;
queue <cow> c;        
bool Used[maxn];       //判断该坐标是否已经走过

int ans = INF;        
int n,k;
bool Juge(int i)
{
    return i>=0&&i<=100000&&!Used[i];    //判断位置是否合法
}
void bfs(int x,int step)
{
    cow buf;
    if(!c.empty())
        c.pop();    
    if(k==x)
    {
        ans = min(ans,step);        ///到达终点,取得最短步长ans
        return;
    }

    buf.step = step+1;
    if(Juge(x-1)&&!Used[x-1])        ///对三种方式遍历,如果下一步可以走,就压入C中
    {
        Used[x-1] = 1;
        buf.x = x-1;
        Used[buf.x] = 1;
        c.push(buf);
    }
    if(Juge(x+1)&&!Used[x+1])
    {
        Used[x+1] = 1;
        buf.x = x+1;
        c.push(buf);
    }
    if(Juge(x*2)&&!Used[x*2])
    {
        Used[x*2] = 1;
        buf.x = x*2;
        c.push(buf);
    }
    if(!c.empty())                
        bfs(c.front().x,c.front().step);    ///搜索下一步
}

int main()
{
    while(cin >> n >> k)
    {
        mem(Used,0);
        ans = INF;
        while(!c.empty())
            c.pop();        ///上面的都是初始化数据
        bfs(n,0);
        cout <<ans << endl;
    }
    return 0;
}



转载于:https://www.cnblogs.com/bestsort/p/10588889.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值