POJ2528 (离散化+线段树)

Mayor's posters
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 89229 Accepted: 25542

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:
  • Every candidate can place exactly one poster on the wall.
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
  • The wall is divided into segments and the width of each segment is one byte.
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall.

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input.

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4
题意:多组输入T。输入n代表有n个海报,接下来n行每行输入l,r代表这张海报的左面和右面的坐标,问最后你可以看到几个海报
思路:1 <= li <= ri <= 10000000,1 <= n <= 10000。先进行离散化,细节需要注意,例如如果样例
  三个海报分别为
1 10
1 3
5 10
则,离散化后坐标为
a[1] = 1
a[2] = 3
a[3] = 5
a[4] = 10;
这样结果就是能看到两个海报而不是三个。
所以可以当a[i] - a[i-1] > 1时,加入一个a[++tail] = a[i-1] + 1;

#include <iostream>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <string>
#include <map>
#include <iomanip>
#include <algorithm>
#include <queue>
#include <stack>
#include <set>
#include <vector>
//const int maxn = 1e5+5;
#define ll long long
#define inf 0x3f
#define FOR(i,a,b) for( int i = a;i <= b;++i)
#define bug cout<<"--------------"<<endl

ll gcd(ll a,ll b){return b?gcd(b,a%b):a;}
ll lcm(ll a,ll b){return a/gcd(a,b)*b;}
const int maxn = 100005+5;
using namespace std;
int a[maxn*2 ],b[maxn * 2],vis[maxn<<3],cun[maxn<<3];
int ans;
int sum[maxn * 4];

void lazy(int q)
{
    if(sum[q])
    {
        sum[q*2] = sum[q];
        sum[q*2+1] = sum[q];
        sum[q] = 0;
    }
}
void query(int q,int l,int r,int L ,int R, int d)
{
    //printf("sssssssssssss\n");
    if(L <= l && R >= r)
    {
        sum[q] = d;
        return ;
    }
    lazy(q);
    int mid = (l + r) / 2;
    if(L <= mid) query(q*2, l , mid , L ,R ,d);
    if(R > mid) query(q*2+1, mid+1,r , L ,R ,d);
}
void lastquery(int q ,int l,int r)
{
    
    if(l == r)
    {
        if(vis[sum[q]] == 0 ) 
        {
            vis[sum[q]] = 1 ;
            //cout<<sum[q]<<endl;
            ans ++;
        }
        return ;
    }
    lazy(q);
    int mid = (l+r) / 2;
    lastquery(q*2,l,mid);
    lastquery(q*2+1,mid+1,r);
}
void clearr()
{
    ans = 0;
    memset(vis ,0 ,sizeof(vis));
    vis[0] = -1;
    memset( sum,0 ,sizeof(sum));
    memset( cun,0 ,sizeof(cun));
    memset( a, 0,sizeof(a));
    memset( b,0 ,sizeof(b));
}
int main()
{

    //freopen("C:\\ACM\\input.txt","r",stdin);
    int T;
    scanf("%d",&T);
    while(T--)
    {
        clearr();
        int tail = 0;
        int n,l,r;
        scanf("%d",&n);
        for(int i = 1;i <= n; ++i)
        {
            scanf("%d%d",&l,&r);
            a[i] = l;
            b[i] = r;
            cun[++tail] = l;
            cun[++tail] = r;            
        }
        sort(cun+1 , cun+1+tail);
        tail = unique(cun+1,cun+1+tail) - cun - 1;
        int temp = tail;
        for(int i = 2;i <= temp; ++i)
        {
            if(cun[i] - cun[i-1] > 1)
            {
                cun[++tail] = cun[i-1] + 1;
            }
        }
        sort(cun+1,cun+1+tail);
        for(int i = 1;i <= n; ++i)
        {
            int x = lower_bound(cun+1,cun+1+tail,a[i]) - cun;
            int y = lower_bound(cun+1,cun+1+tail,b[i]) - cun;  
            query(1, 1, tail ,x , y, i );
        }
        lastquery(1,1,tail);
        
        printf("%d\n",ans );
    }

}

 

 

转载于:https://www.cnblogs.com/jrfr/p/11543139.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值