杭电acm1042 求n!

N!

http://acm.hdu.edu.cn/showproblem.php?pid=1042

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22101 Accepted Submission(s): 5904


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!

Input
One N in one line, process to the end of file.

Output
For each N, output N! in one line.

Sample Input
1 2 3

Sample Output
1 2 6
 
#include<iostream>
using namespace std;
int main()
{
	int result[40000];
	int num;
	while(cin>>num)
	{
		int height=1;  //结果的最高位
		if(num>10000||num<0) break;
		result[0]=1;
		for(int i=1;i<=num;i++)
		{
			int res=0;  //进位
			for(int j=0;j<height;j++)
			{
				int buf=result[j]*i+res;  //计算结果
				result[j]=buf;   //取当前位
				res=buf/10;   //计算进位
			}
			while(res)
			{
				result[height++]=res;  //取当前位
				res/=10;  //计算进位
			}
		}
		for(int k=height-1;k>=0;k--)
			cout<<result[k];
		cout<<endl;
	}
	return 0;
}

转载于:https://www.cnblogs.com/pcoda/archive/2011/05/28/2104563.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值