台州 OJ 2649 More is better 并查集

描述

 

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

 

输入

 

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

 

输出

 

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

 
样例输入

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

样例输出

4
2

 

 

并查集,求元素数量最多的集合,输出这个数量。(PS:求一个节点的祖先时,对这一条路径上所有的结点都进行更新,压缩路径,不然会超时)

#include <iostream>
#include <cstring>
#include <map>
using namespace std;

const int MAX = 10000005;

bool mark[MAX];        //标记结点是否存在 
int parent[MAX];
int mp[MAX];    //一个集合对应的元素数量
int n; 
int ans;

inline void addNode(int x);
inline void addEdge(int u, int v);
int getParent(int x);

int main(){
//    freopen("input.txt", "r", stdin);
//    freopen("output.txt", "w", stdout);
    
    while(~scanf("%d", &n)){
        if(n == 0){
            printf("1\n");
            continue;
        }
        int u, v;
        memset(mark, 0, sizeof(mark));
        ans = 0;
        for(int i=1; i<=n; i++){
            scanf("%d%d", &u, &v);
            addNode(u);  addNode(v);
            addEdge(u, v);
        }
        
        printf("%d\n", ans);
    }
    
    return 0; 
}

inline void addNode(int x){
    if(mark[x] == 0){
        mark[x] = 1;
        parent[x] = x;
        mp[x] = 1;
    }
}

inline void addEdge(int u, int v){
    int pu = getParent(u);
    int pv = getParent(v);
    if(pu == pv)            //如果是两个相同的集合,就不做操作 
        return ;
    mp[pu] += mp[pv];        //合并后,集合数量增加 
    ans = max(ans, mp[pu]);        //更新答案 
    parent[pv] = pu;            //进行合并 
}

int getParent(int x){
    if(parent[x] == x)
        return x;
    parent[x] = getParent(parent[x]);        //路径压缩,不进行的话会超时 
    return parent[x];
}

 

 

 

转载于:https://www.cnblogs.com/lighter-blog/p/7358141.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值