HDU OJ Beans

Beans

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 9   Accepted Submission(s) : 5
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description

Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.

Now, how much qualities can you eat and then get ?

Input

There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M*N<=200000.

Output

For each case, you just output the MAX qualities you can eat and then get.

Sample Input
4 6
11 0 7 5 13 9
78 4 81 6 22 4
1 40 9 34 16 10
11 22 0 33 39 6
Sample Output
242

分析:

根据题意可知,要选择某个值,则其上下两行和旁边两个都不能选,即要选某个值,受其上一行有没有选择和左边那个有没有选择的影响(因为下一行和右边的可由这个值有否选择来确定其能否选择)。要两次dp,第一次dp每一行,即如若要选择该行,最大值sum[i]是多少;第二次dp整个矩阵,其实也就是把第一次dp出的m行最大值sum[]按照第一次的方法dp一下,得出最优解~~
        设dp[i][0]表示那一行的第 i 个值不选,dp[i][1]表示要选,a[i]表示那一行的第 i 个值,则:
           dp[ i ][ 0 ] = max (dp[i-1][0], dp[i-1][1])     【第 i 个值不选,则前一个值可选亦可不选】
           dp[ i ][ 1 ] = dp[i-1][0] + a[ i ]                   【第 i 个值要选,则前一个值一定不可选】

代码如下:

#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;

int num[200005];
int dp[200005][2];
int sum[200005];

int caculate(int a[],int n)
{
    int i;
    for(i=1;i<=n;i++)
    {
        dp[i][0]=max(dp[i-1][0],dp[i-1][1]);
        dp[i][1]=dp[i-1][0]+a[i];
    }
    return dp[n][1]>dp[n][0]?dp[n][1]:dp[n][0];
}

int main()
{
    int i,j;
    int m,n;
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        for(i=1;i<=m;i++)
        {
            for(j=1;j<=n;j++)
            {
                scanf("%d",&num[j]);
            }
            sum[i]=caculate(num,n);
        }
        printf("%d\n",caculate(sum,m));
    }
    return 0;
}

转载于:https://www.cnblogs.com/lzmfywz/articles/2355881.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值