hdu 4046 Panda

Panda

Time Limit: 10000/4000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 674    Accepted Submission(s): 245


Problem Description
When I wrote down this letter, you may have been on the airplane to U.S.
We have known for 15 years, which has exceeded one-fifth of my whole life. I still remember the first time we went to the movies, the first time we went for a walk together. I still remember the smiling face you wore when you were dressing in front of the mirror. I love your smile and your shining eyes. When you are with me, every second is wonderful.
The more expectation I had, the more disappointment I got. You said you would like to go to U.S.I know what you really meant. I respect your decision. Gravitation is not responsible for people falling in love. I will always be your best friend. I know the way is difficult. Every minute thinking of giving up, thinking of the reason why you have held on for so long, just keep going on. Whenever you’re having a bad day, remember this: I LOVE YOU.
I will keep waiting, until you come back. Look into my eyes and you will see what you mean to me.
There are two most fortunate stories in my life: one is finally the time I love you exhausted. the other is that long time ago on a particular day I met you.
Saerdna.

It comes back to several years ago. I still remember your immature face.
The yellowed picture under the table might evoke the countless memory. The boy will keep the last appointment with the girl, miss the heavy rain in those years, miss the love in those years. Having tried to conquer the world, only to find that in the end, you are the world. I want to tell you I didn’t forget. Starry night, I will hold you tightly.

Saerdna loves Panda so much, and also you know that Panda has two colors, black and white.
Saerdna wants to share his love with Panda, so he writes a love letter by just black and white.
The love letter is too long and Panda has not that much time to see the whole letter.
But it's easy to read the letter, because Saerdna hides his love in the letter by using the three continuous key words that are white, black and white.
But Panda doesn't know how many Saerdna's love there are in the letter.
Can you help Panda?
 

Input
An integer T means the number of test cases T<=100
For each test case:
First line is two integers n, m
n means the length of the letter, m means the query of the Panda. n<=50000,m<=10000
The next line has n characters 'b' or 'w', 'b' means black, 'w' means white.
The next m lines
Each line has two type
Type 0: answer how many love between L and R. (0<=L<=R<n)
Type 1: change the kth character to ch(0<=k<n and ch is ‘b’ or ‘w’)
 

Output
For each test case, output the case number first.
The answer of the question.
 

Sample Input
2

5 2
bwbwb
0 0 4
0 1 3
5 5
wbwbw
0 0 4
0 0 2
0 2 4
1 2 b
0 0 4
 

Sample Output
Case 1:
1
1
Case 2:
2
1
1
0
 

Source
题意:给出一个字符串由w和b组成,两种抄做,一种是把第i个字符改成字符c;另一种是询问i~j之间连续的三个字符是由wbw组合的个数;
思路:
  把一个长度为n的字符,转化成下标由1~n-2的节点,其下标表示的是以它为中间的连续三个字符,其值1表示是wbw,否者为0;然后就是更新的时候比较复杂点,每更新一个字母,可能可以引起三个节点的的值的变化,只有前后值不一样才更新;
代码:
#include <cstdlib>
#include <iostream>
#define lowbit(x)  x&(-x)
using namespace std;
int n,m,c[100010];
bool is[100010];
char s[50100];

  void insert(int p,int d)
  {
      for(int i=p;i<=n-2;i+=lowbit(i))
      {
          c[i]+=d;
      }    
  }
 
  int query(int p)
  {
      int sum=0;
      for(int i=p;i>0;i-=lowbit(i))
      {
          sum+=c[i];   
      }
      return sum;   
  }
int main(int argc, char *argv[])
{
    int t,cas=1;
    scanf("%d",&t);
    while(t--)
    {
       printf("Case %d:\n",cas++);
        scanf("%d%d",&n,&m);     
        scanf("%s",s);
        for(int i=1;i<=n;i++)
           c[i]=is[i]=0;
        for(int i=1;i<=n-2;i++)
        {
           if(s[i-1]=='w'&&s[i]=='b'&&s[i+1]=='w')
           {
             insert(i,1);
             is[i]=1;
           }
        }
        int a,l,r;
        char c;
        while(m--)
        {
            scanf("%d",&a);
            if(a==0)
            {
                 scanf("%d%d",&l,&r);
                 if(r-l<=1)  { puts("0"); continue; }
                 int sum1=query(l);
                 int sum2=query(r-1);
                 printf("%d\n",sum2-sum1);
            }
            else
            {
                scanf("%d %c",&l,&c);
                 if(s[l]==c)     continue;
                 else
                 {
                     s[l]=c;
                    int  i =l;
                     if(l>=1&&l<=n-2)
                     {
                          if(s[l-1]=='w'&&s[l]=='b'&&s[l+1]=='w')
                          {
                              if(!is[l]) { insert(i,1);  is[i]=1; }
                               
                          }
                          else if(is[i])
                           {   insert(i,-1);  is[i]=0;}
                     }
                    if(l>=2)
                     {
                          if(s[l-2]=='w'&&s[l-1]=='b'&&s[l]=='w')
                          {
                              if(!is[i-1]) { insert(i-1,1);  is[i-1]=1; }
                               
                          }
                          else if(is[i-1])
                           {   insert(i-1,-1);  is[i-1]=0;}
                     }
                     if(l+2<=n-1)
                      {
                          if(s[l]=='w'&&s[l+1]=='b'&&s[l+2]=='w')
                          {
                              if(!is[i+1]) { insert(i+1,1);  is[i+1]=1; }
                               
                          }
                          else if(is[i+1])
                           {   insert(i+1,-1);  is[i+1]=0;}
                     }
                }
               // printf("%s\n",s);
            }         
        }
    }
    system("PAUSE");
    return EXIT_SUCCESS;
}

转载于:https://www.cnblogs.com/one--world--one--dream/archive/2011/09/29/2195869.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值