hdu-5792 World is Exploding(容斥+树状数组)

题目链接:

World is Exploding

Time Limit: 2000/1000 MS (Java/Others)  

  Memory Limit: 65536/65536 K (Java/Others)


Problem Description
Given a sequence A with length n,count how many quadruple (a,b,c,d) satisfies:  abcd,1a<bn,1c<dn,Aa<Ab,Ac>Ad.
 

 

Input
The input consists of multiple test cases. 
Each test case begin with an integer n in a single line.

The next line contains n integers  A1,A2An.
1n50000
0Ai1e9
 

 

Output
For each test case,output a line contains an integer.
 

 

Sample Input
 
4
2 4 1 3
4
1 2 3 4
 

 

Sample Output
 
1
0
 
题意:
 
问符合题目给的四元组有多少个;
 
思路:
 
容斥,先算出a,b,c,d满足Aa<Ab&&Ac<Ad的个数,再减去a==c,a==d,b==c,b==d的个数,就是答案了,因为不可能有两个相等的出现;然后就是用树状数组
求pres[i],preb[i],nexs[i],nexb[i];分别表示第i个数前边比它小,比它大,后面比它小比它大的个数具体的看代码吧;
 
AC代码:
 
/************************************************
┆  ┏┓   ┏┓ ┆   
┆┏┛┻━━━┛┻┓ ┆
┆┃       ┃ ┆
┆┃   ━   ┃ ┆
┆┃ ┳┛ ┗┳ ┃ ┆
┆┃       ┃ ┆ 
┆┃   ┻   ┃ ┆
┆┗━┓    ┏━┛ ┆
┆  ┃    ┃  ┆      
┆  ┃    ┗━━━┓ ┆
┆  ┃  AC代马   ┣┓┆
┆  ┃           ┏┛┆
┆  ┗┓┓┏━┳┓┏┛ ┆
┆   ┃┫┫ ┃┫┫ ┆
┆   ┗┻┛ ┗┻┛ ┆      
************************************************ */ 
 
 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <bits/stdc++.h>
#include <stack>
 
using namespace std;
 
#define For(i,j,n) for(int i=j;i<=n;i++)
#define mst(ss,b) memset(ss,b,sizeof(ss));
 
typedef  long long LL;
 
template<class T> void read(T&num) {
    char CH; bool F=false;
    for(CH=getchar();CH<'0'||CH>'9';F= CH=='-',CH=getchar());
    for(num=0;CH>='0'&&CH<='9';num=num*10+CH-'0',CH=getchar());
    F && (num=-num);
}
int stk[70], tp;
template<class T> inline void print(T p) {
    if(!p) { puts("0"); return; }
    while(p) stk[++ tp] = p%10, p/=10;
    while(tp) putchar(stk[tp--] + '0');
    putchar('\n');
}
 
const LL mod=1e9+7;
const double PI=acos(-1.0);
const int inf=1e9;
const int N=5e4+10;
const int maxn=1e3+14;
const double eps=1e-8;

int n,fa[N],pres[N],preb[N],nexs[N],nexb[N],sum[N];
struct node
{
    int a,id;
}po[N];
int cmp(node x,node y)
{
    if(x.a==y.a)return x.id<y.id;
    return x.a<y.a;
}
int cmp1(node x,node y)
{
    if(x.a==y.a)return x.id<y.id;
    return x.a>y.a;
}

int lowbit(int x){return x&(-x);}

inline void update(int x)
{
    while(x<=n)
    {
        sum[x]++;
        x+=lowbit(x);
    }
}
int query(int x)
{
    int s=0;
    while(x)
    {
        s+=sum[x];
        x-=lowbit(x);
    }
    return s;
}
int main()
{      
        while(scanf("%d",&n)!=EOF)
        {
            For(i,1,n)read(po[i].a),po[i].id=i;
            sort(po+1,po+n+1,cmp);
            po[0].a=-1;
            mst(sum,0);
            For(i,1,n)
            {
                if(po[i].a==po[i-1].a)fa[i]=fa[i-1];
                else fa[i]=i;
                pres[po[i].id]=query(po[i].id)-(i-fa[i]);
                nexs[po[i].id]=fa[i]-1-pres[po[i].id];
                update(po[i].id);
            }
            mst(sum,0);
            sort(po+1,po+n+1,cmp1);
            For(i,1,n)
            {
                if(po[i].a==po[i-1].a)fa[i]=fa[i-1];
                else fa[i]=i;
                preb[po[i].id]=query(po[i].id)-(i-fa[i]);
                nexb[po[i].id]=fa[i]-1-preb[po[i].id];
                update(po[i].id);
            }
            sort(po+1,po+n+1,cmp1);
            LL ans1=0,ans2=0,ans;
            For(i,1,n)
            {
                ans1=ans1+pres[i];
                ans2=ans2+preb[i];
            }
            ans=ans1*ans2;
            For(i,1,n)
            {
                ans=ans-nexs[i]*nexb[i];//a==c
                ans=ans-preb[i]*nexb[i];//a==d
                ans=ans-pres[i]*nexs[i];//b==c
                ans=ans-pres[i]*preb[i];//b==d
            }         
            cout<<ans<<endl;
        }
        return 0;
}

  

转载于:https://www.cnblogs.com/zhangchengc919/p/5732776.html

本项目是一个基于SSM(Spring+SpringMVC+MyBatis)框架和Vue.js前端技术的大学生第二课堂系统,旨在为大学生提供一个便捷、高效的学习和实践平台。项目包含了完整的数据库设计、后端Java代码实现以及前端Vue.js页面展示,适合计算机相关专业的毕设学生和需要进行项目实战练习的Java学习者。 在功能方面,系统主要实现了以下几个模块:用户管理、课程管理、活动管理、成绩管理和通知公告。用户管理模块支持学生和教师的注册、登录及权限管理;课程管理模块允许教师上传课程资料、设置课程时间,并由学生进行选课;活动管理模块提供了活动发布、报名和签到功能,鼓励学生参与课外实践活动;成绩管理模块则用于记录和查询学生的课程成绩和活动参与情况;通知公告模块则实时发布学校或班级的最新通知和公告。 技术实现上,后端采用SSM框架进行开发,Spring负责业务逻辑层,SpringMVC处理Web请求,MyBatis进行数据库操作,确保了系统的稳定性和扩展性。前端则使用Vue.js框架,结合Axios进行数据请求,实现了前后端分离,提升了用户体验和开发效率。 该项目不仅提供了完整的源代码和相关文档,还包括了详细的数据库设计文档和项目部署指南,为学习和实践提供了便利。对于基础较好的学习者,可以根据自己的需求在此基础上进行功能扩展和优化,进一步提升自己的技术水平和项目实战能力。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值