HDU 2391 Filthy Rich (dp)

题目连接

Problem Description
They say that in Phrygia, the streets are paved with gold. You’re currently on vacation in Phrygia, and to your astonishment you discover that this is to be taken literally: small heaps of gold are distributed throughout the city. On a certain day, the Phrygians even allow all the tourists to collect as much gold as they can in a limited rectangular area. As it happens, this day is tomorrow, and you decide to become filthy rich on this day. All the other tourists decided the same however, so it’s going to get crowded. Thus, you only have one chance to cross the field. What is the best way to do so?

Given a rectangular map and amounts of gold on every field, determine the maximum amount of gold you can collect when starting in the upper left corner of the map and moving to the adjacent field in the east, south, or south-east in each step, until you end up in the lower right corner.

Input
The input starts with a line containing a single integer, the number of test cases.
Each test case starts with a line, containing the two integers r and c, separated by a space (1 <= r, c <= 1000). This line is followed by r rows, each containing c many integers, separated by a space. These integers tell you how much gold is on each field. The amount of gold never negative.
The maximum amount of gold will always fit in an int.

Output
For each test case, write a line containing “Scenario #i:”, where i is the number of the test case, followed by a line containing the maximum amount of gold you can collect in this test case. Finish each test case with an empty line.

Sample Input
1
3 4
1 10 8 8
0 0 1 8
0 27 0 4

Sample Output
Scenario #1:
42

分析:
首行给出T,代表有T组数据。每组数据第一行给出n,m代表接着有n行m列的数据。起点在左上角,终点在右下角,每一步可以向下向右向右下走,输出途中最大数字和。

思路:动态规划,dp[i][j]代表到达(i,j)能获取的最大数字和
状态转移方程
dp[i][j]=max(dp[i][j],dpi][j-1]+tu[i][j]),j-1>=0;
dp[i][j]=max(dp[i][j],dp[i-1][j]+tu[i][j]),i-1>=0;
dp[i][j]=max(dp[i][j],dp[i-1][j-1]+tu[i][j]),i-1>=0,j-1>=0;

代码:

#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
int tu[1010][1010];
int dp[1010][1010];
int main()
{
    int T;
    scanf("%d",&T);
    for(int t=1;t<=T;t++)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<m; j++)
                scanf("%d",&tu[i][j]);
        }
        memset(dp,0,sizeof(dp));
        dp[0][0]=tu[0][0];
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++)
            {
                if(j-1>=0&&dp[i][j]<dp[i][j-1]+tu[i][j])
                    dp[i][j]=dp[i][j-1]+tu[i][j];
                if(i-1>=0&&dp[i][j]<dp[i-1][j]+tu[i][j])
                    dp[i][j]=dp[i-1][j]+tu[i][j];
                if(j-1>=0&&i-1>=0&&dp[i][j]<dp[i-1][j-1]+tu[i][j])
                    dp[i][j]=dp[i-1][j-1]+tu[i][j];
            }
            printf("Scenario #%d:\n",t);
            printf("%d\n\n",dp[n-1][m-1]);
    }
    return 0;
}

转载于:https://www.cnblogs.com/cmmdc/p/7862180.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值