UESTC 482 Charitable Exchange(优先队列+bfs)

Charitable Exchange

Time Limit: 4000/2000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others)
Submit  Status

Have you ever heard a star charity show called Charitable Exchange? In this show, a famous star starts with a small item which values 11 yuan. Then, through the efforts of repeatedly exchanges which continuously increase the value of item in hand, he (she) finally brings back a valuable item and donates it to the needy.

In each exchange, one can exchange for an item of Vi yuan if he (she) has an item values more than or equal to RiRi yuan, with a time cost of TiTi minutes.

Now, you task is help the star to exchange for an item which values more than or equal to MM yuan with the minimum time.

Input

The first line of the input is TT (no more than 2020), which stands for the number of test cases you need to solve.

For each case, two integers NNMM (1N1051≤N≤1051M1091≤M≤109) in the first line indicates the number of available exchanges and the expected value of final item. Then NN lines follow, each line describes an exchange with 33 integers ViViRiRiTiTi (1RiVi1091≤Ri≤Vi≤1091Ti1091≤Ti≤109).

Output

For every test case, you should output Case #k: first, where kk indicates the case number and counts from 11. Then output the minimum time. Output 1−1 if no solution can be found.

Sample input and output

Sample Input Sample Output
3
3 10
5 1 3
8 2 5
10 9 2
4 5
2 1 1
3 2 1
4 3 1
8 4 1
5 9
5 1 1
10 4 10
8 1 10
11 6 1
7 3 8
 
优先队列 贪心+bfs
 
#include <iostream>


#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>
#include <queue>

using namespace std;
#define MAX 100000
struct Node
{
	long long int v;
	long long int r;
	long long int t;
}a[MAX+5];
struct node
{
    long long int value;
    long long int time;
	bool friend operator <(node a,node b)
	{
		return a.time>b.time;
	}

};
priority_queue<node> q;
int n,m;
int right1;
int cmp(Node a,Node b)
{
    return a.r<b.r;
}
long long int bfs()
{
    node term1;
    term1.value=1;term1.time=0;
    q.push(term1);
    int left=1,i;
    while(!q.empty())
    {
		node term2=q.top();
        q.pop();
        if(term2.value>=m)
        {
            return term2.time;
        }
		for(i=left;i<=right1;i++)
        {
            if(term2.value>=a[i].r&&term2.value<a[i].v)
            {
                node temp;
                temp.value=a[i].v;
                temp.time=term2.time+a[i].t;
				q.push(temp);
            }
			if(term2.value<a[i].r)
				break;
           
        }
		left=i;
       
    }
	return -1;
}
int main()
{
    int t;
    int cas=0;
    scanf("%d",&t);
    long long int vv,rr,tt;
    while(t--)
    {
        scanf("%d%d",&n,&m);
        right1=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%lld%lld%lld",&vv,&rr,&tt);
            if(vv==rr)
                continue;
            a[++right1].v=vv;a[right1].r=rr;a[right1].t=tt;
        }
		while(!q.empty())
			q.pop();
        sort(a+1,a+1+right1,cmp);
        printf("Case #%d: %lld\n",++cas,bfs());
    }
    return 0;
}


Case #1: -1
Case #2: 4
Case #3: 10

转载于:https://www.cnblogs.com/dacc123/p/8228650.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值