HDU - 1546 ZOJ - 2750 Idiomatic Phrases Game 成语接龙SPFA+map

Idiomatic Phrases Game

Tom is playing a game called Idiomatic Phrases Game. An idiom consists of several Chinese characters and has a certain meaning. This game will give Tom two idioms. He should build a list of idioms and the list starts and ends with the two given idioms. For every two adjacent idioms, the last Chinese character of the former idiom should be the same as the first character of the latter one. For each time, Tom has a dictionary that he must pick idioms from and each idiom in the dictionary has a value indicates how long Tom will take to find the next proper idiom in the final list. Now you are asked to write a program to compute the shortest time Tom will take by giving you the idiom dictionary. 

InputThe input consists of several test cases. Each test case contains an idiom dictionary. The dictionary is started by an integer N (0 < N < 1000) in one line. The following is N lines. Each line contains an integer T (the time Tom will take to work out) and an idiom. One idiom consists of several Chinese characters (at least 3) and one Chinese character consists of four hex digit (i.e., 0 to 9 and A to F). Note that the first and last idioms in the dictionary are the source and target idioms in the game. The input ends up with a case that N = 0. Do not process this case. 
OutputOne line for each case. Output an integer indicating the shortest time Tome will take. If the list can not be built, please output -1.Sample Input

5
5 12345978ABCD2341
5 23415608ACBD3412
7 34125678AEFD4123
15 23415673ACC34123
4 41235673FBCD2156
2
20 12345678ABCD
30 DCBF5432167D
0

Sample Output

17
-1


题意:每个成语由至少三个字组成,每个字为四个16进制的数字(0~F)组成。两个成语首尾相接,消耗Tom对前一个成语的查询时间,求最小查询时间。
思路:最短路问题,注意对建图的处理。map将成语的首尾字以数字点的形式存储。使用map前必须初始化。

#include<stdio.h>
#include<string.h>
#include<string>
#include<map>
#include<deque>
#include<vector>
#define MAX 2005
#define INF 0x3f3f3f3f
using namespace std;

map<string,int> mp;

struct Node{
    int v,w;
}node;
vector<Node> edge[MAX];
int dis[MAX],b[MAX],w[MAX],bg[MAX],ed[MAX];
int n;

void spfa(int k)
{
    int i;
    deque<int> q;
    for(i=1;i<=n;i++){
        dis[i]=INF;
    }
    memset(b,0,sizeof(b));
    b[k]=1;
    dis[k]=0;
    q.push_back(k);
    while(q.size()){
        int u=q.front();
        for(i=0;i<edge[u].size();i++){
            int v=edge[u][i].v;
            int w=edge[u][i].w;
            if(dis[v]>dis[u]+w){
                dis[v]=dis[u]+w;
                if(b[v]==0){
                    b[v]=1;
                    if(dis[v]>dis[u]) q.push_back(v);
                    else q.push_front(v);
                }
            }
        }
        b[u]=0;
        q.pop_front();
    }
}
int main()
{
    int m,u,v,i,j;
    char s[200],s1[200],s2[200];
    while(scanf("%d",&n)&&n!=0){
        m=0;
        for(i=1;i<=2002;i++){
            edge[i].clear();
            mp.clear();    //!!
        }
        for(i=1;i<=n;i++){
            scanf("%d%s",&w[i],s);
            strncpy(s1,s,4);
            strncpy(s2,s+strlen(s)-4,4);
            s1[4]='\0';s2[4]='\0';
            if(!mp[s1]) mp[s1]=++m;
            if(!mp[s2]) mp[s2]=++m;
            u=mp[s1];v=mp[s2];
            bg[i]=u;ed[i]=v;
        }
        for(i=1;i<=n;i++){
            for(j=1;j<=n;j++){
                if(i!=j&&ed[i]==bg[j]){
                    node.v=j;
                    node.w=w[i];
                    edge[i].push_back(node);
                }
            }
        }
        spfa(1);
        if(n==1||dis[n]==INF) printf("-1\n");
        else printf("%d\n",dis[n]);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/yzm10/p/7279905.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值