Oil Deposits----深搜问题

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 
 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 
 

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets. 
 

Sample Input

1 1
*
3 5
*@*@*
**@ **
*@*@*
1 8
@@****@*
5 5
* * * * @
*@@ * @
*@ * * @
@@@* @
@@* * @
0 0
 

Sample Output

0
1
2
2
 
 
 题意:在输入的N*n的图案中找到‘油田’的个数;
油田即‘@’一个@周围的八个图案若有@的则视为一个油田。
 
 
#include <iostream>
#include <stdio.h>
using namespace std;
#define N 110
char ch[N][N];
int x, y;
void fin (int i, int j)
{
    if (ch[i][j]!='@' || i<0 || i>x ||j<0 || j>y)
        return ;
    else
    {
        ch[i][j]='*';            //深搜  向八个方向递归 并将ch[i][j]赋值为‘*’
        fin (i, j-1);
        fin (i, j+1);
        fin (i-1, j-1);
        fin (i-1, j);
        fin (i-1, j+1);
        fin (i+1, j-1);
        fin (i+1, j);
        fin (i+1, j+1);
    }

}
int main ()
{
    int i, j, num;
    while(cin >> x >> y, x!=0)
    {
        num = 0;
        for(i = 0; i<x; i++)
        {
            for (j = 0; j<y; j++)  // 输入 地图
            {
                cin >> ch[i][j];
            }
        }
        for(i = 0; i<x; i++)
        {
            for (j = 0; j<y; j++)
            {
                if (ch[i][j]=='@')      //   对油田的个数进行统计 因为fin函数中对统计过的全赋值为“*”所以不用担心重复的问题;
                {
                    fin (i, j);
                    num++;
                }
            }
        }
        cout << num <<endl;
    }
}


//ps这个是用c++写的 目前只会输入 输出 头文件什么的 都是直接复制的 = =

  

                              

 
 

转载于:https://www.cnblogs.com/yishilin/p/4238231.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值