hdu 4920 Matrix multiplication bitset优化常数

Matrix multiplication

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)


Problem Description
Given two matrices A and B of size n×n, find the product of them.

bobo hates big integers. So you are only asked to find the result modulo 3.
 

 

Input
The input consists of several tests. For each tests:

The first line contains n (1≤n≤800). Each of the following n lines contain n integers -- the description of the matrix A. The j-th integer in the i-th line equals A ij. The next n lines describe the matrix B in similar format (0≤A ij,B ij≤10 9).
 

 

Output
For each tests:

Print n lines. Each of them contain n integers -- the matrix A×B in similar format.
 

 

Sample Input
1 0 1 2 0 1 2 3 4 5 6 7
 

 

Sample Output
0 0 1 2 1
 

 

Author
Xiaoxu Guo (ftiasch)
 

 

Source
题意:给你两个矩阵,求矩阵相乘%3;
思路:正常思路n*n*n求解(运气好可以ac。。。),看了下数据范围由于mod=3,所以利用bitset标记每行1,2,0的位置,取并集就可以得到相同位置的个数;
   这样就可以优化最后的一个n。详见代码;
#include<bits/stdc++.h>
using namespace std;
#define ll long long
#define pi (4*atan(1.0))
#define eps 1e-14
const int N=1e3+10,M=1e6+10,inf=1e9+10;
const ll INF=1e18+10,mod=2147493647;
int n;
bitset<N>a[N][5],b[N][5];
int ans(int i,int j)
{
    int u=(a[i][1]&b[j][1]).count(),v=(a[i][1]&b[j][2]).count();
    int x=(a[i][2]&b[j][1]).count(),y=(b[j][2]&a[i][2]).count();
    return u+v*2+x*2+y*4;
}
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++)
            for(int j=0;j<=3;j++)
            a[i][j].reset(),b[i][j].reset();
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
            {
                int x;
                scanf("%d",&x);
                a[i][x%3].set(j);
            }
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
            {
                int x;
                scanf("%d",&x);
                b[j][x%3].set(i);
            }
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
                printf("%d%c",ans(i,j)%3,(j!=n-1?' ':'\n'));
        }
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/jhz033/p/6244402.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值