Codeforces Round #250 (Div. 2)C. The Child and Toy(贪心)

传送门

Description

On Children's Day, the child got a toy from Delayyy as a present. However, the child is so naughty that he can't wait to destroy the toy.

The toy consists of n parts and m ropes. Each rope links two parts, but every pair of parts is linked by at most one rope. To split the toy, the child must remove all its parts. The child can remove a single part at a time, and each remove consume an energy. Let's define an energy value of part i as vi. The child spend vf1 + vf2 + ... + vfk energy for removing part i where f1, f2, ..., fk are the parts that are directly connected to the i-th and haven't been removed.

Help the child to find out, what is the minimum total energy he should spend to remove all n parts.

Input

The first line contains two integers n and m (1 ≤ n ≤ 1000; 0 ≤ m ≤ 2000). The second line contains n integers: v1, v2, ..., vn(0 ≤ vi ≤ 105). Then followed m lines, each line contains two integers xi and yi, representing a rope from part xi to part yi(1 ≤ xi, yi ≤ nxi ≠ yi).

Consider all the parts are numbered from 1 to n.

Output

Output the minimum total energy the child should spend to remove all n parts of the toy.

Sample Input

4 3
10 20 30 40
1 4
1 2
2 3

4 4
100 100 100 100
1 2
2 3
2 4
3 4

7 10
40 10 20 10 20 80 40
1 5
4 7
4 5
5 2
5 7
6 4
1 6
1 3
4 3
1 4

Sample Output

40

400

160

Note

One of the optimal sequence of actions in the first sample is:

  • First, remove part 3, cost of the action is 20.
  • Then, remove part 2, cost of the action is 10.
  • Next, remove part 4, cost of the action is 10.
  • At last, remove part 1, cost of the action is 0.

So the total energy the child paid is 20 + 10 + 10 + 0 = 40, which is the minimum.

In the second sample, the child will spend 400 no matter in what order he will remove the parts.

思路

题意:熊孩子玩一个玩具,玩具由n个部件,m条绳子组成,每条绳子连接两个部件。小孩比较顽皮,要将玩具拆成不可分割的部件,每次拆掉一个部件所需的能量花费为其他与之相连的部件的能量值的和。问最小的总代价是多少。

题解:最小总代价,那么每次拆必须先拆能量值大的部件,这样才能保证总代价最小,因此每次读入绳子将两个部件相连时候,只要选择能量值较小的,就是结果。

 

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1005;
int val[maxn];

int main()
{
	int n,m,u,v,res = 0;
	scanf("%d%d",&n,&m);
	for (int i = 1;i <= n;i++)	scanf("%d",&val[i]);
	while (m--)
	{
		scanf("%d%d",&u,&v);
		res += min(val[u],val[v]);
	}
	printf("%d\n",res);
	return 0;
}

  

转载于:https://www.cnblogs.com/ZhaoxiCheung/p/6804993.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值