POJ 2353 Ministry

Ministry
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4220 Accepted: 1348 Special Judge

Description

Mr. F. wants to get a document be signed by a minister. A minister signs a document only if it is approved by his ministry. The ministry is an M-floor building with floors numbered from 1 to M, 1<=M<=100. Each floor has N rooms (1<=N<=500) also numbered from 1 to N. In each room there is one (and only one) official. 

A document is approved by the ministry only if it is signed by at least one official from the M-th floor. An official signs a document only if at least one of the following conditions is satisfied: 
a. the official works on the 1st floor; 
b. the document is signed by the official working in the room with the same number but situated one floor below; 
c. the document is signed by an official working in a neighbouring room (rooms are neighbouring if they are situated on the same floor and their numbers differ by one).

Each official collects a fee for signing a document. The fee is a positive integer not exceeding 10^9. 

You should find the cheapest way to approve the document. 

Input

The first line of an input file contains two integers, separated by space. The first integer M represents the number of floors in the building, and the second integer N represents the number of rooms per floor. Each of the next M lines contains N integers separated with spaces that describe fees (the k-th integer at l-th line is the fee required by the official working in the k-th room at the l-th floor).

Output

You should print the numbers of rooms (one per line) in the order they should be visited to approve the document in the cheapest way. If there are more than one way leading to the cheapest cost you may print an any of them.

Sample Input

3 4
10 10 1 10
2 2 2 10
1 10 10 10

Sample Output

3
3
2
1
1
题目大意:有一栋m层的房子,每层n个房间,如果该房间在第一层或者该房间的上一层的房间或者左右任意一个房间被访问才能访问该房间,问从第一层到最后一层走过的房间的权值和最小的路径。
#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;

int fee[105][505];
int dp[105][505];
int path[105][505];
int ans[50005];

int main()
{
    int m, n;
    int s;
    while(scanf("%d%d", &m, &n) != EOF)
    {
        memset(dp, 0, sizeof(dp));
        memset(path, 0, sizeof(path));
        memset(ans, 0, sizeof(ans));
        for (int i = 1; i <= m; i++)
        {
            for (int j = 1; j <= n; j++)
            {
                scanf("%d", &fee[i][j]);
            }
        }
        for (int i = 1; i <= n; i++)
        {
            dp[1][i] = fee[1][i];
            path[1][i] = i;
        }
        for (int i = 2; i <= m; i++)
        {
            dp[i][1] = dp[i - 1][1] + fee[i][1];
            path[i][1] = 1;
            for (int j = 2; j <= n; j++)
            {
                if (dp[i - 1][j] < dp[i][j - 1])
                {
                    dp[i][j] = fee[i][j] + dp[i - 1][j];
                    path[i][j] = j;
                }
                else
                {
                    dp[i][j] = fee[i][j] + dp[i][j- 1];
                    path[i][j] = j - 1;
                }
            }
            for (int j = n - 1; j > 0; j--)
            {
                if (dp[i][j + 1] + fee[i][j] < dp[i][j])
                {
                    dp[i][j] = dp[i][j + 1] + fee[i][j];
                    path[i][j] = j + 1;
                }
            }
        }
        int temp = 0x7fffffff;
        for (int i = 1; i <= n; i++)
        {
            if (temp > dp[m][i])
            {
                temp = dp[m][i];
                s = i;
            }
        }
        int nCount = 0;
        int x = m;
        ans[0] = s;
        while (x != 1)
        {
            nCount++;
            ans[nCount] = path[x][ans[nCount - 1]];
            if (ans[nCount] == ans[nCount - 1])
            {
                x--;
            }
        }
        for (int i = nCount; i >=0; i--)
        {
            printf("%d\n", ans[i]);
        }
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/lzmfywz/p/3233429.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
SQLAlchemy 是一个 SQL 工具包和对象关系映射(ORM)库,用于 Python 编程语言。它提供了一个高级的 SQL 工具和对象关系映射工具,允许开发者以 Python 类和对象的形式操作数据库,而无需编写大量的 SQL 语句。SQLAlchemy 建立在 DBAPI 之上,支持多种数据库后端,如 SQLite, MySQL, PostgreSQL 等。 SQLAlchemy 的核心功能: 对象关系映射(ORM): SQLAlchemy 允许开发者使用 Python 类来表示数据库表,使用类的实例表示表中的行。 开发者可以定义类之间的关系(如一对多、多对多),SQLAlchemy 会自动处理这些关系在数据库中的映射。 通过 ORM,开发者可以像操作 Python 对象一样操作数据库,这大大简化了数据库操作的复杂性。 表达式语言: SQLAlchemy 提供了一个丰富的 SQL 表达式语言,允许开发者以 Python 表达式的方式编写复杂的 SQL 查询。 表达式语言提供了对 SQL 语句的灵活控制,同时保持了代码的可读性和可维护性。 数据库引擎和连接池: SQLAlchemy 支持多种数据库后端,并且为每种后端提供了对应的数据库引擎。 它还提供了连接池管理功能,以优化数据库连接的创建、使用和释放。 会话管理: SQLAlchemy 使用会话(Session)来管理对象的持久化状态。 会话提供了一个工作单元(unit of work)和身份映射(identity map)的概念,使得对象的状态管理和查询更加高效。 事件系统: SQLAlchemy 提供了一个事件系统,允许开发者在 ORM 的各个生命周期阶段插入自定义的钩子函数。 这使得开发者可以在对象加载、修改、删除等操作时执行额外的逻辑。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值