Faulty Odometer(九进制数)

Faulty Odometer
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9301 Accepted: 5759

Description

You are given a car odometer which displays the miles traveled as an integer. The odometer has a defect, however: it proceeds from the digit 3 to the digit 5, always skipping over the digit 4. This defect shows up in all positions (the one's, the ten's, the hundred's, etc.). For example, if the odometer displays 15339 and the car travels one mile, odometer reading changes to 15350 (instead of 15340).

Input

Each line of input contains a positive integer in the range 1..999999999 which represents an odometer reading. (Leading zeros will not appear in the input.) The end of input is indicated by a line containing a single 0. You may assume that no odometer reading will contain the digit 4.

Output

Each line of input will produce exactly one line of output, which will contain: the odometer reading from the input, a colon, one blank space, and the actual number of miles traveled by the car.

Sample Input

13
15
2003
2005
239
250
1399
1500
999999
0

Sample Output

13: 12
15: 13
2003: 1461
2005: 1462
239: 197
250: 198
1399: 1052
1500: 1053
999999: 531440
题解:油表坏了,遇到4就变成5,其实就是一个九进制数,注意大于4的要减一,我却吓模拟了半天。。。
代码:
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cmath>

using namespace std;
int *getary(int N){
    int a[15];
    int *b;
    b = (int *)malloc(sizeof(int) * 15); 
    memset(a, 0, sizeof(a));
    int i = 0;
    while(N){
        a[i ++] = N % 10;
        N /= 10;
    }
    b[0] = i;
    for(int j = 1; j <= i; j++){
        b[j] = a[i - j];
    }
    return b;
}

int main(){
    
    int N;
    while((scanf("%d", &N)), N){
        int *a = getary(N);
        
        int temp = 0;
        for(int i = 1; i <= a[0]; i++){
            if(a[i] > 4){
                a[i] --;
            }
            temp = temp * 9 + a[i];
        }
        printf("%d: %d\n", N, temp);
    }
    
    return 0;
} 

 



转载于:https://www.cnblogs.com/handsomecui/p/6563455.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值