hdu 1394(树状数组)

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16948    Accepted Submission(s): 10292


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

 

Output
For each case, output the minimum inversion number on a single line.
 

 

Sample Input
10 1 3 6 9 0 8 5 7 4 2
 

 

Sample Output
16
 

 

Author
CHEN, Gaoli
 

 

Source
 
题意:求出所有变换的数组里面逆序数最小的那一个的逆序数的个数。
题解:树状数组求出最初始的逆序数后,可以通过变换出所有的逆序数,第一个为a[i] ,那么当它放到最后一个去的时候,整个序列逆序数个数多了 n - a[i] 个,少了 a[i] - 1个。
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stack>
#include <vector>
#include <algorithm>
using namespace std;
const int N = 5005;
int a[N],b[N],c[N],n;
int lowbit(int x){
    return x&(-x);
}
void update(int idx,int v){
    for(int i=idx;i<=n;i+=lowbit(i)){
        c[i]+=v;
    }
}
int getsum(int idx){
    int sum = 0;
    for(int i=idx;i>=1;i-=lowbit(i)){
        sum+=c[i];
    }
    return sum;
}

int main()
{
    while(scanf("%d",&n)!=EOF){
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
            a[i]++;
        }
        memset(c,0,sizeof(c));
       /* for(int i=1;i<=n;i++){

            int id = 1;
            for(int j=i;j<=n;j++){
                b[id++]=a[j];
            }
            for(int j=1;j<i;j++){
                b[id++]=a[j];
            }
            int cnt = 0;
            for(int j=1;j<=n;j++){
                update(b[j],1);
                cnt+=j-getsum(b[j]);
            }
            res = min(res,cnt);
        }*/
        long long cnt = 0;
        for(int i=1;i<=n;i++){
            update(a[i],1);
            cnt+=i-getsum(a[i]);
        }
        long long res = cnt;
        for(int i=1;i<=n;i++){
            cnt = cnt+(n-a[i])-(a[i]-1);
            res = min(res,cnt);
        }
        printf("%lld\n",res);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/liyinggang/p/5655478.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值