POJ 2387 Til the Cows Come Home(最短路 Dijkstra/spfa)

Til the Cows Come Home
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 46727 Accepted: 15899

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.

 

Dijkstra()

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
typedef __int64 LL;
const int maxn = 2005;
const int INF = 0x3f3f3f3f;
struct Edge{
	int u,v,next;
	LL w;
	bool operator < (const Edge & a)const
	{
		return w > a.w;
	}
}edge[maxn<<1] ;
int tot = 0,head[maxn];
bool vis[maxn];
LL dis[maxn];

void addedge(int u,int v,LL w)
{
	edge[tot] = (Edge){u,v,head[u],w
	};
	head[u] = tot++;
}

void Dijkstra()
{
	priority_queue<Edge>que;
	Edge p; 
	memset(dis,INF,sizeof(dis));
	memset(vis,false,sizeof(vis)); 
	p.v = 1;
	que.push(p);
	dis[1] = 0;
	while (!que.empty())
	{
		p = que.top();
		que.pop();
		int u = p.v;
		if (vis[u])	continue;
		vis[u] = true;
		for (int i = head[u];i != -1;i = edge[i].next)
		{
			int v = edge[i].v;
			if (dis[u] + edge[i].w < dis[v])
			{
				dis[v] = dis[u] + edge[i].w;
				p.u = u,p.v = v,p.w = dis[v];
				que.push(p);
			}
		}
	}
}

int main()
{
	//freopen("input.txt","r",stdin);
	int T,N,u,v;
	LL w;
	memset(head,-1,sizeof(head)); 
	scanf("%d%d",&T,&N);
	for (int i = 0;i < T;i++)
	{
		scanf("%d%d%I64d",&u,&v,&w);
		addedge(u,v,w);
		addedge(v,u,w);
	}
	Dijkstra();
	printf("%I64d\n",dis[N]);
	return 0;
} 

spfa()

#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;
const int INF =  0x3f3f3f3f;
const int MAX_N = 1005;
bool flag[MAX_N];
int  edge[MAX_N][MAX_N];

void spfa(int n)
{
	int dis[MAX_N];
	queue<int>que;
	memset(flag,false,sizeof(flag));
	memset(dis,0x3f3f3f3f,sizeof(dis));
	
	dis[1] = 0;
	que.push(1);
	flag[1] = true;
	
	while (!que.empty())
	{
		int curval = que.front();
		que.pop();
		flag[curval] = false;
		
		for (int i = 1;i <= n;i++)
		{
			if (dis[curval] < dis[i] - edge[curval][i])
			{
				dis[i] = dis[curval] + edge[curval][i];
				
				if (!flag[i])
				{
					que.push(i);
					flag[i] = true;
				}
			}
		}
	}
	printf("%d\n",dis[n]);
}

int main()
{
	int N,T;
	while (~scanf("%d%d",&T,&N))
	{
		int u,v,w;
		for (int i = 1;i <= N;i++)
		{
			for (int j = 1;j <= i;j++)
			{
				if (i == j) edge[i][j] = 0;
				else edge [i][j] = edge[j][i] = INF;
			}
		}
		for (int i = 0;i < T;i++)
		{
			scanf("%d%d%d",&u,&v,&w);
			/*if (w < edge[u][v])
			{
				edge[u][v] = edge[v][u] = w;
			}*/
			edge[u][v] = edge[v][u] = min(w,edge[u][v]);
		}
		spfa(N);
	}
	return 0;
}

  

 

转载于:https://www.cnblogs.com/ZhaoxiCheung/p/6087549.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园的建设目标是通过数据整合、全面共享,实现校园内教学、科研、管理、服务流程的数字化、信息化、智能化和多媒体化,以提高资源利用率和管理效率,确保校园安全。 智慧校园的建设思路包括构建统一支撑平台、建立完善管理体系、大数据辅助决策和建设校园智慧环境。通过云架构的数据中心与智慧的学习、办公环境,实现日常教学活动、资源建设情况、学业水平情况的全面统计和分析,为决策提供辅助。此外,智慧校园还涵盖了多媒体教学、智慧录播、电子图书馆、VR教室等多种教学模式,以及校园网络、智慧班牌、校园广播等教务管理功能,旨在提升教学品质和管理水平。 智慧校园的详细方案设计进一步细化了教学、教务、安防和运维等多个方面的应用。例如,在智慧教学领域,通过多媒体教学、智慧录播、电子图书馆等技术,实现教学资源的共享和教学模式的创新。在智慧教务方面,校园网络、考场监控、智慧班牌等系统为校园管理提供了便捷和高效。智慧安防系统包括视频监控、一键报警、阳光厨房等,确保校园安全。智慧运维则通过综合管理平台、设备管理、能效管理和资产管理,实现校园设施的智能化管理。 智慧校园的优势和价值体现在个性化互动的智慧教学、协同高效的校园管理、无处不在的校园学习、全面感知的校园环境和轻松便捷的校园生活等方面。通过智慧校园的建设,可以促进教育资源的均衡化,提高教育质量和管理效率,同时保障校园安全和提升师生的学习体验。 总之,智慧校园解决方案通过整合现代信息技术,如云计算、大数据、物联网和人工智能,为教育行业带来了革命性的变革。它不仅提高了教育的质量和效率,还为师生创造了一个更加安全、便捷和富有智慧的学习与生活环境。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值