HelloWorldForU ---九度Online Judge

题目描述:

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h    d
e     l
l      r
lowo


That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

输入:

There are multiple test cases.Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

输出:

For each test case, print the input string in the shape of U as specified in the description.

样例输入:
helloworld!
ac.jobdu.com
样例输出:
h   !
e   d
l   l
lowor
a    m
c    o
.    c
jobdu.
 
   
代码:
 
   
#include <iostream>
#include <string>

using namespace std;


int main(int argc, char** args) {
	string s;
	while (cin >> s && s.size() >= 5 && s.size() <= 80) {
		int len = s.size();
		int height = (len - 2) / 3;
		int width = len - 2 * height;

		for (int i = 0; i < height; ++ i) {
			cout.setf(ios::left);
			cout.width(width - 1);
			cout << s[i];
			cout << s[len - (i + 1)] << endl;

			if (i == (height - 1)) {
				string substr = s.substr(height, width);
				cout << substr << endl;
			}
		}
	}
}

代码没有提交过,不知道能不能AC。

转载于:https://www.cnblogs.com/java20130722/archive/2013/03/15/3206807.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值