多重背包求解POJ 1726 Cash Machine

Cash Machine
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 19960 Accepted: 6954

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 ... nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

Sample Input

735 3 4 125 6 5 3 350
633 4 500 30 6 100 1 5 0 1
735 00 3 10 100 10 50 10 10

Sample Output

735
630
0
0
 
 
方法一:
#include<stdio.h>
#include<string.h>
int c[1001],w[1010],n[1010],count[100010];
int dp[100010];
int P;
int max(int a,int b)
{
	return a > b ? a : b;
}
int min(int x ,int y)
{
	return x < y ? x : y;
}
void ZeroOnePack(int c,int w)
{
	int p;
	for( p = P; p >= c; p--)
		dp[p] = max(dp[p],dp[p - c] + w ); 
}
void CompletePack(int c,int w)
{
	int p;
	for(p = c; p <= P; p++)
		dp[p] = max(dp[p],dp[p - c] + w);
}
int main()
{
	int N,i,k;
	while(scanf("%d%d",&P,&N) != EOF)
	{
		//输入N种货币的面值和数量
		for(i = 0; i < N; i++)
		{
			scanf("%d%d",&n[i],&w[i]);
			c[i] = w[i]; //体积等于价值
		}
		memset(dp,0,sizeof(int)*(P+1));
		for(i = 0; i < N; i++)
		{
			if(n[i] * c[i] >= P)
			{
				CompletePack(c[i],w[i]);
			}
			else
			{
				k = 1; 
				while(k < n[i])
				{
					ZeroOnePack(k*c[i],k*w[i]);
					n[i] -= k;
					k *= 2;
				}
				ZeroOnePack(c[i]*n[i],n[i]*w[i]);
			}
		}
		printf("%d\n",dp[P]);
	}
	return 0;
}

 
 
方法二:
#include<stdio.h>
#include<string.h>
int c[1001],w[1010],n[1010],count[100010];
int dp[100010];
int P;
int main()
{
	i nt N,i,k;
	while(scanf("%d%d",&P,&N) != EOF)
	{
		//输入N种货币的面值和数量
		for(i = 0; i < N; i++)
		{ 
			scanf("%d%d",&n[i],&w[i]);
			c[i] = w[i]; //体积等于价值
		} 
		memset(dp,0,sizeof(int)*(P+1));
		for(i = 0; i < N; i++)
		{ 
			memset(count,0,sizeof(int)*(P+1));
			for( j = w[i]; j <= P; j++)
				if(dp[j] < dp[j - c[i]] + w[i] && count[j-c[i]] < n[i])
				{
					dp[j] = dp[j-c[i]] + w[i];
					count[j] = count[j-c[i]] + 1 ;
				}
		}
		printf("%d\n",dp[P]);
	}
	return 0;
}

转载于:https://www.cnblogs.com/LUO257316/archive/2012/08/07/3220866.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值