九度OJ 1076 N的阶乘 -- 大数运算

题目地址:http://ac.jobdu.com/problem.php?pid=1076

 

题目描述:

 输入一个正整数N,输出N的阶乘。

输入:

正整数N(0<=N<=1000)

输出:

 输入可能包括多组数据,对于每一组输入数据,输出N的阶乘

样例输入:
4
5
15
样例输出:
24
120
1307674368000
/*
 * Main.c
 *
 *  Created on: 2014年1月26日
 *      Author: Shaobo
 */
#include <stdio.h>
 
#define N 10010
 
int main(void){
    int result[N];
    int i, j, n;
 
    while (scanf ("%d", &n) != EOF){
        result[0] = result[1] = 1;
        for (i=2; i<N; ++i)
            result[i] = 0;
        for (i=2; i<=n; ++i){
            for (j=1; j<=result[0]; ++j)
                result[j] *= i;
            for (j=1; j<=result[0]; ++j){
                if (result[j] >= 10){
                    result[j+1] += result[j]/10;
                    result[j] %= 10;
                    if (j == result[0])
                        ++result[0];
                }
            }
        }
        for (i=result[0]; i>=1; --i)
            printf ("%d", result[i]);
        putchar ('\n');
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/liushaobo/p/4373851.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值