Problem 1008 Hay Points

Problem Description

Each employee of a bureaucracy has a job description - a few paragraphs that describe the responsibilities of the job. The employee's job description, combined with other factors, such as seniority, is used to determine his or her salary.

The Hay Point system frees the Human Resources department from having to make an intelligent judgement as to the value of the employee; the job description is merely scanned for words and phrases that indicate responsibility. In particular, job descriptions that indicate control over a large budget or management over a large number of people yield high Hay Point scores.

You are to implement a simplified Hay Point system. You will be given a Hay Point dictionary and a number of job descriptions. For each job description you are to compute the salary associated with the job, according to the system.

The first line of input contains 2 positive integers: m <= 1000, the number of words in the Hay Point dictionary, and n <= 100, the number of job descriptions. m lines follow; each contains a word (a string of up to 16 lower-case letters) and a dollar value (a real number between 0 and 1,000,000). Following the dictionary are the n job descriptions. Each job description consists of one or more lines of text; for your convenience the text has been converted to lower case and has no characters other than letters, numbers, and spaces. Each job description is terminated by a line containing a period.

For each job description, output the corresponding salary computed as the sum of the Hay Point values for all words that appear in the description. Words that do not appear in the dictionary have a value of 0.

Sample Input

7 2 administer 100000 spending 200000 manage 50000 responsibility 25000 expertise 100 skill 50 money 75000 the incumbent will administer the spending of kindergarden milk money and exercise responsibility for making change he or she will share responsibility for the task of managing the money with the assistant whose skill and expertise shall ensure the successful spending exercise . this individual must have the skill to perform a heart transplant and expertise in rocket science .

Sample Output

700150
150
 
题目比较简单,但对于我这种英语渣渣来说太痛苦了,连看带猜在加上样例终于把题意搞懂了,就是每个单词对应一个数字,在一大堆单词里找到有多少个和那些单词相等,加上他们相应的数字就行,so easy!
ExpandedBlockStart.gif
 1 #include <iostream>
 2  using  namespace std;
 3 
 4  struct w
 5 {
 6         string s;
 7         int p;
 8 }k[ 1100];
 9  int main()
10 {
11      int n,m,sum;
12      string str;
13      while (cin>>n>>m)
14     {
15            for ( int i= 1;i<=n;i++)
16           cin>>k[i].s>>k[i].p;
17           sum= 0;
18            for ( int i= 1;i<=m;i++)
19           {
20                while (cin>>str&&str!= " . ")
21               {
22                      for ( int j= 1;j<=n;j++)
23                      if (k[j].s==str)
24                     sum+=k[j].p;
25               }
26               cout <<sum<<endl;
27               sum= 0;
28           }
29     }
30      return  0;
31 }
View Code

转载于:https://www.cnblogs.com/arno-my-boke/p/4392015.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值