hdu3371 Connect the Cities

Connect the Cities

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6362    Accepted Submission(s): 1838

Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  
 

Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
 

Output
For each case, output the least money you need to take, if it’s impossible, just output -1.
 

Sample Input
 
  
1 6 4 3 1 4 2 2 6 1 2 3 5 3 4 33 2 1 2 2 1 3 3 4 5 6
 

Sample Output
 
  
1
 
还是kruskal算法。题意就是已经有些点连到一起了,就是有的边和点不考虑了,在剩下的边里面选。注意,可能出现不是联通分量的情况。直接拿另外一道题目改改就AC了。题目链接 继续畅通工程
#include <iostream>
#include <algorithm>
using namespace std;
const int MAX=55000;
struct Edge
{
	int vex1;
	int vex2;
	int weight;
};
int vset[MAX];
bool operator <(const Edge&E1,const Edge&E2)
{
	return E1.weight<E2.weight;
}
int GetParent(int i)//路径压缩的并查集啦
{
	if(vset[i]!=i)
		vset[i]=GetParent(vset[i]);
	return vset[i];
}
void kruskal(Edge E[],int m,int e)
{
	int sum=0;
	for(int j=0;j<m;j++)
	{
		int p1=GetParent(E[j].vex1);
		int p2=GetParent(E[j].vex2);
		if(p1!=p2)
		{
			sum+=E[j].weight;
			vset[p2]=p1;
			e--;
		}
	}
	if(!e)//判断边数是否为0,若为0则表示所有边都找到了。否则的话,就不是连通图了。输出-1
		printf("%d\n",sum);
	else
		printf("-1\n");
}
int main()
{
	int c;
	scanf("%d",&c);
	while(c--)
	{
		int n,m,k;
		int v1,v2,dist;
		int i;
		Edge E[MAX];
		scanf("%d%d%d",&n,&m,&k);
		int e=n-1;//构成最小生成树所需边数
		for(i=1;i<=n;i++)
			vset[i]=i;
		for(i=0;i<m;i++)
		{
			scanf("%d%d%d",&v1,&v2,&dist);
			E[i].vex1=v1;
			E[i].vex2=v2;
			E[i].weight=dist;
		}
		int t,p1,p2;
		for(i=0;i<k;i++)
		{
			scanf("%d",&t);
			scanf("%d",&v1);
			p1=GetParent(v1);
			while(--t)//注意不是t--两者循环次数差1次
			{
				scanf("%d",&v2);
				p2=GetParent(v2);
				if(p1==p2)
					continue;
				vset[p2]=p1;
				e--;//联通两个点之后,即找到了一条生成树的边。所以还剩下的边减一条。
			}
		}
		sort(E,E+m);
		kruskal(E,m,e);
	}
	return 0;
}


转载于:https://www.cnblogs.com/unclejelly/p/4082148.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值