16-最少回文数组

                     

                Splits the string

                    时间限制: 1000 ms  |  内存限制:65535 KB
                          难度: 3
描述
Hrdv is interested in a string,especially the palindrome string.So he wants some palindrome string.

A sequence of characters is a palindrome if it is the same written forwards and backwards. For example, 'abeba' is a palindrome, but 'abcd' is not.

A partition of a sequence of characters is a list of one or more disjoint non-empty groups of consecutive characters whose concatenation yields the initial sequence. For example, ('race', 'car') is a partition of 'racecar' into two groups.

Given a sequence of characters, we can always create a partition of these characters such that each group in the partition is a palindrome! Given this observation it is natural to ask: what is the minimum number of groups needed for a given string such that every group is a palindrome?

For example:

'racecar' is already a palindrome, therefore it can be partitioned into one group.
'fastcar' does not contain any non-trivial palindromes, so it must be partitioned as ('f', 'a', 's', 't', 'c', 'a', 'r').
'aaadbccb' can be partitioned as ('aaa', 'd', 'bccb').
Input begins with the number n of test cases. Each test case consists of a single line of between 1 and 1000 lowercase letters, with no whitespace within.

输入
Each test case consists of a single line of between 1 and 1000 lowercase letters, with no whitespace within.
输出
For each test case, output a line containing the minimum number of groups required to partition the input into groups of palindromes.
样例输入
racecar
fastcar
aaadbccb
样例输出
1
7
3
上传者
TC_胡仁东
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int dp[1005];
char a[1005];

int judge(int i, int j){

//    while(a[i] == a[j]){
//        if(i == j)
//            break;
//        i++;
//        if(i == j)
//            break;
//        j--;
//        if(i == j)
//            break;
//    }
//    if(i == j && a[i] == a[j])
//        return 1;
//    else
//        return 0;
    //上面判断回文太麻烦了
    int mid = (i + j) >> 1;
    int m = i;
    for(int i; i <= mid; i++){
        if(a[i] != a[j - i + m])  //注意j - i时要加上数组片段传来的起点. 
            return 0;
    } 
    return 1;
}

int main(){
    while(~scanf("%s", a + 1)){
        int len = strlen(a + 1);
        for(int i = 1; i <= len; i++){
            dp[i] = i;
            for(int j = 1; j <= i; j++){
                if(a[i] == a[j] && judge(j, i)){        //dp[i]表示的是0到i的最少回文串数 
                    dp[i] = min(dp[i], dp[j - 1] + 1);  //j从是从0开始扫描到i如果发现j到i是回文,
                                                        //则j到i为一个回文串,就可以得到这个递推关系 
                }
            }
        }    
        printf("%d\n", dp[len]);     
    }
    return 0;
} 

  

转载于:https://www.cnblogs.com/zhumengdexiaobai/p/7429674.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值