[ACM] ZOJ Martian Addition (20进制的两个大数相加)

Martian Addition

Time Limit: 2 Seconds       Memory Limit: 65536 KB

  In the 22nd Century, scientists have discovered intelligent residents live on the Mars. Martians are very fond of mathematics. Every year, they would hold an Arithmetic Contest on Mars (ACM). The task of the contest is to calculate the sum of two 100-digit numbers, and the winner is the one who uses least time. This year they also invite people on Earth to join the contest.
  As the only delegate of Earth, you're sent to Mars to demonstrate the power of mankind. Fortunately you have taken your laptop computer with you which can help you do the job quickly. Now the remaining problem is only to write a short program to calculate the sum of 2 given numbers. However, before you begin to program, you remember that the Martians use a 20-based number system as they usually have 20 fingers. 

Input:
You're given several pairs of Martian numbers, each number on a line. 
Martian number consists of digits from 0 to 9, and lower case letters from a to j (lower case letters starting from a to present 10, 11, ..., 19). 
The length of the given number is never greater than 100.

Output:
For each pair of numbers, write the sum of the 2 numbers in a single line.

Sample Input:
1234567890
abcdefghij
99999jjjjj
9999900001

Sample Output:
bdfi02467j
iiiij00000

Source:  Zhejiang University Local Contest 2002, Preliminary


解题思路:

求两个20进制的数的和,用数组模拟相加就能够。

代码:

#include <iostream>
#include <algorithm>
#include <string.h>
#include <stdio.h>
#include <stdlib.h>
#include <map>
using namespace std;
map<int,char>change;

char num[105];
int add1[105];
int add2[105];
int ans[105];
int jin[105];

void prepare()
{
	change[0]='0';change[1]='1';change[2]='2';change[3]='3';
	change[4]='4';change[5]='5';change[6]='6';change[7]='7';
	change[8]='8';change[9]='9';change[10]='a';change[11]='b';
	change[12]='c';change[13]='d';change[14]='e';change[15]='f';
	change[16]='g';change[17]='h';change[18]='i';change[19]='j';
}

int main()
{
	prepare();
	while(cin>>num)
	{
	    memset(add1,0,sizeof(add1));
	    memset(add2,0,sizeof(add2));
	    memset(jin,0,sizeof(jin));
		int len1=strlen(num);
		int t=0;
		for(int i=len1-1;i>=0;--i)
		{
			if(!(num[i]>='0'&&num[i]<='9'))
				add1[t++]=num[i]-87;
			else
				add1[t++]=num[i]-'0';
		}
		cin>>num;
		int len2=strlen(num);
		t=0;
		for(int i=len2-1;i>=0;--i)
		{
			if(!(num[i]>='0'&&num[i]<='9'))
				add2[t++]=num[i]-87;
			else
				add2[t++]=num[i]-'0';
		}
		//输入处理完成
		//for(int i=0;i<len2;i++)
          //  cout<<add2[i];
        //cout<<endl;

		int len=max(len1,len2);
		for(int i=0;i<=len;i++)
        {
            int temp=add1[i]+add2[i]+jin[i];
            if(temp>=40)
            {
                ans[i]=temp-40;
                jin[i+1]=2;
            }
            else if(temp>=20)
            {
                ans[i]=temp-20;
                jin[i+1]=1;
            }
            else
                ans[i]=temp;
        }
        if(ans[len])
            cout<<change[ans[len]];
        for(int i=len-1;i>=0;i--)
            cout<<change[ans[i]];
        cout<<endl;
	}
	return 0;
}


转载于:https://www.cnblogs.com/brucemengbm/p/6731468.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值