HDU 1116 Play on Words(欧拉回路+并查集)

传送门:

http://acm.hdu.edu.cn/showproblem.php?pid=1116

Play on Words

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9939    Accepted Submission(s): 3399


Problem Description
Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.
 

 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list.
 

 

Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times.
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.".
 

 

Sample Input
3 2 acm ibm 3 acm malform mouse 2 ok ok
 

 

Sample Output
The door cannot be opened. Ordering is possible. The door cannot be opened.
 

 

Source
 

 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1217  1325  1269  1596  1281 
 
题目意思:
给你n个单词,问你这n个单词能不能相连成一条链或者一个环
相连的条件是前面一个单词的最后一个字母等于后面这个单词的第一个字母
分析:对每个单词,单词头和单词尾的字母看成一个结点,然后根据规则,可以相连的就连起来,用并查集查看所有单词结点的连通性,如果连成的图不是一个连通图,那么这些结点肯定不可以构成环或者无分叉的链
如果是连通图,再根据欧拉回路性质(一条链或环性质)判断
对链来说:链头的入度=出度-1,链尾的入度=出度+1,链中间结点的出度=入度
对环来说:每个结点的出度=入读
 
code:
#include<iostream>
#include<stdio.h>
#include<memory.h>
using namespace std;
#define max_v 30
int in[max_v],out[max_v];
int vis[max_v];
int pa[max_v];
int rk[max_v];
int n;
void make_set(int x)
{
    pa[x]=x;
    rk[x]=0;
}
int find_set(int x)
{
    if(x!=pa[x])
        pa[x]=find_set(pa[x]);
    return pa[x];
}
void union_set(int x,int y)
{
    x=find_set(x);
    y=find_set(y);
    if(x==y)
        return ;
    if(rk[x]>rk[y])//按秩合并
        pa[y]=x;
    else
    {
        pa[x]=y;
        if(rk[x]==rk[y])
            rk[y]++;
    }
}
void init()//初始化
{
    memset(in,0,sizeof(in));
    memset(out,0,sizeof(out));
    memset(vis,0,sizeof(vis));
    for(int i=0; i<max_v; i++)//并查集初始化
        make_set(i);
}
int main()
{
    int t;
    scanf("%d",&t);
    string str;
    while(t--)
    {
        init();
        scanf("%d",&n);
        for(int i=0; i<n; i++)
        {
            cin>>str;
            int x=str[0]-'a';
            int y=str[str.length()-1]-'a';
            in[x]++;//入度
            out[y]++;//出度
            vis[x]=1;//出现过的标记
            vis[y]=1;
            union_set(x,y);//合并
        }
        int root=0;
        for(int i=0; i<max_v; i++)
        {
            if(vis[i]==1&&pa[i]==i)//判断连通性
            {
                root++;
                if(root>=2)
                    break;
            }
        }
        if(root>=2)//不连通
        {
            printf("The door cannot be opened.\n");
            continue;
        }
        int s1=0,s2=0,s3=0;
        for(int i=0; i<max_v; i++)
        {
            if(vis[i]&&in[i]!=out[i])
            {
                if(in[i]==out[i]-1)//链头
                    s1++;
                else if(in[i]==out[i]+1)//链尾
                    s2++;
                else//不是链
                    s3++;
            }
        }
        if(s3)
            printf("The door cannot be opened.\n");
        else if((s1==1&&s2==1)||(s1==0&&s2==0))//链或者环
            printf("Ordering is possible.\n");
        else
            printf("The door cannot be opened.\n");
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/yinbiao/p/9449767.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值