hdu---5095---Linearization of the kernel functions in SVM

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5095

 

分析:当a[i]不为0的时候,就有输出;

 输出内容:1.系数为正数且不是第一个位置输出一个'+';

      2.当系数为-1时且不是最后一个常数时输出一个'-';

      3.系数不是-1或1或者是最后那个常数时输出这个数;

      4.最后一个位置没有字符要输出。

 

Problem Description
SVM(Support Vector Machine)is an important classification tool, which has a wide range of applications in cluster analysis, community division and so on. SVM The kernel functions used in SVM have many forms. Here we only discuss the function of the form f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j. By introducing new variables p, q, r, u, v, w, the linearization of the function f(x,y,z) is realized by setting the correspondence x^2  <-> p, y^2 <-> q, z^2 <-> r, xy <-> u, yz <-> v, zx <-> w and the function f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j can be written as g(p,q,r,u,v,w,x,y,z) = ap + bq + cr + du + ev + fw + gx + hy + iz + j, which is a linear function with 9 variables.
Now your task is to write a program to change f into g.
 

 

Input
The input of the first line is an integer T, which is the number of test data (T<120). Then T data follows. For each data, there are 10 integer numbers on one line, which are the coefficients and constant a, b, c, d, e, f, g, h, i, j of the function f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j.
 

 

Output
For each input function, print its correspondent linear function with 9 variables in conventional way on one line.
 

 

Sample Input
2 0 46 3 4 -5 -22 -8 -32 24 27 2 31 -5 0 0 12 0 0 -49 12
 

 

Sample Output
46q+3r+4u-5v-22w-8x-32y+24z+27 2p+31q-5r+12w-49z+12
 

 

Source
 

 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5808  5807  5806  5805  5804 
 
#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>
#include<vector>
#include<algorithm>
using namespace std;
#define PI 3.1415926

const int maxn=1000007;
const int INF=0x3f3f3f3f;

char str[10]={"pqruvwxyz"};
int a[10];

int main()
{
    int T;
    scanf("%d", &T);

    while(T--)
    {
        for(int i=0; i<10; i++)
            scanf("%d", &a[i]);

        int f=0;
        for(int i=0; i<10; i++)
        {
            if(a[i])///当a[i]不为0的时候,就有输出;
            {
                if(f && a[i]>0)printf("+");///系数为正数且不是第一个位置输出一个'+';

                if(a[i]==-1 && i!=9)printf("-");///当系数为-1时且不是最后一个常数时输出一个'-';

                if((a[i]!=-1&&a[i]!=1) || (i==9))printf("%d", a[i]);///系数不是-1或1或者是最后那个常数时输出这个数

                if(i!=9)printf("%c", str[i]);///最后一个位置没有字符要输出

                f=1;///标记判断

            }
        }
        printf("\n");
    }
    return 0;
}

 

 

转载于:https://www.cnblogs.com/w-y-1/p/5750311.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值