POJ 1125 Stockbroker Grapevine 最短路基本题

Stockbroker Grapevine
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 20558 Accepted: 11141

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

Source


英文真的很长很难懂,但算法是很简单的,就是一个floyd 3重循环

主要意思就是几个炒股的要通风报信,求通风报信的最短时间(可同时通风报信给多人)

第一行就是输入炒股的人的个数n

接下来n行 

比如 第一行第一个数字是这个炒股的1号能通报给几个人 后面的数字是给第几号需要多少时间

第二行就是炒股的2号 blabla以此类推 

注意这个传递方向是有向的...


求从第几号炒股的开始传信号 所需的时间最少 求出这个最短时间 

强调一下信号能同时发出去哟,所以构建的邻接矩阵都不用怎么处理直接就能得出这个值

下面是详细有注释代码

#include <set>
#include <map>
#include <list>
#include <cmath>
#include <ctime>
#include <deque>
#include <queue>
#include <stack>
#include <cctype>
#include <cstdio>
#include <string>
#include <vector>
#include <cassert>
#include <cstdlib>
#include <cstring>
#include <sstream>
#include <iostream>
#include <algorithm>
using namespace std;
int main()
{
//	freopen("in.txt","r",stdin);
	int n;
	while(~scanf("%d",&n) && n!=0)
	{
		int dis[101][101]; // 构建邻接矩阵
		int i,j,k,p;
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				dis[i][j]=0x3f3f3f3f; //给所有点赋最大值
		for(i=1;i<=n;i++)
		{
			scanf("%d",&p);
			while(p--)
			{
				scanf("%d%d",&j,&k);
				dis[i][j]=k;  //两个点的路径(本题就是两个投资人之间通风报信的时间)入表
			}
		}

		/*该注释能输出构建的邻接表
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
				cout<<dis[i][j]<<" ";				
			cout<<endl;
		}
		*/  
		
		//开始floyd  复杂度O(n^3) 
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				for(k=1;k<=n;k++)
					if(dis[j][k] > dis[j][i] + dis[i][k] )   //比较两点间是 直达快 还是 绕路快,更新邻接表
						dis[j][k] = dis[j][i] + dis[i][k];

		/*该注释能输出更新后的邻接表
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
				cout<<dis[i][j]<<" ";				
			cout<<endl;
		}
		*/ 

		//接下来就是找出( 是哪些点能走通其他所有点 && 这些点中[到其他所有点的距离的最大值]的最小值)
		int min=0x7fffffff,geti;
		for(i=1;i<=n;i++)
		{
			int max=-0x7fffffff;
			for(j=1;j<=n;j++)
			{
				if(i!=j && dis[i][j]>max)
					max= dis[i][j];
			}
			if(min>max)
			{
				min=max;
				geti=i;
			}
		}
		cout<<geti<<" "<<min<<endl;
	}
    return 0;
}



转载于:https://www.cnblogs.com/Felix-F/archive/2012/07/19/3223669.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值