HDU 5723 Abandoned country

HDU 5723 Abandoned country

Time Limit: 8000/4000 MS (Java/Others) Memory Limit: > 65536/65536 K (Java/Others)
Total Submission(s): 7454 Accepted Submission(s): 1821

Problem Description
An abandoned country has n(n≤100000) villages which are numbered from 1 to n. Since abandoned for a long time, the roads need to be re-built. There are m(m≤1000000) roads to be re-built, the length of each road is wi(wi≤1000000). Guaranteed that any two wi are different. The roads made all the villages connected directly or indirectly before destroyed. Every road will cost the same value of its length to rebuild. The king wants to use the minimum cost to make all the villages connected with each other directly or indirectly. After the roads are re-built, the king asks a men as messenger. The king will select any two different points as starting point or the destination with the same probability. Now the king asks you to tell him the minimum cost and the minimum expectations length the messenger will walk.

Input
The first line contains an integer T(T≤10) which indicates the number of test cases.

For each test case, the first line contains two integers n,m indicate the number of villages and the number of roads to be re-built. Next m lines, each line have three number i,j,wi, the length of a road connecting the village i and the village j is wi.

Output
output the minimum cost and minimum Expectations with two decimal places. They separated by a space.

Sample Input

1

4 6

1 2 1

2 3 2

3 4 3

4 1 4

1 3 5

2 4 6

Sample Output

6 3.33

Author

HIT

题目解析

题面可能有些问题,但是直接kruskal,然后求期望就行了,期望等于 每条边经过的次数 * 该边的权值累加。每条边经过的次数等于 子节点个数(包含自身) * (n - 子节点个数(包含自身)。当然用dp也能做,可能会麻烦一点

代码

#include<bits/stdc++.h>
#define CLR(a,b) memset(a,b,sizeof(a))
using namespace std;
typedef long long ll;
const int maxn = 1e5 + 10;
struct Edge
{
    int from,to,v;
}edge[maxn*10];
int fa[maxn],vis[maxn],num[maxn];
int n,m;
ll sum;
vector<Edge> edge0[maxn];

int find(int x)
{
    return fa[x] == x ? x : fa[x] = find(fa[x]);
}

bool cmp(Edge a, Edge b)
{
    return a.v <b.v;
}

ll kruskal()
{
    for(int i = 1; i <= n; i++) fa[i] = i;
    sort(edge+1,edge+m+1,cmp);
    ll ans = 0;
    int cnt = 0;
    for(int i = 1; i <= m; i++){
        int x = find(edge[i].from);
        int y = find(edge[i].to);
        if(x != y){
            fa[x] = y;
            ans += (ll)edge[i].v;
            Edge tmp;
            tmp.from = edge[i].from,tmp.to = edge[i].to,tmp.v = edge[i].v;
            edge0[edge[i].from].push_back(tmp);
            swap(tmp.from,tmp.to);
            edge0[edge[i].to].push_back(tmp);
            if(++cnt == n-1) break;
        }
    }
    return ans;
}

void dfs(int u)
{
    for(int i = 0; i < edge0[u].size(); i++){
        int v = edge0[u][i].to;
        if(vis[v]) continue;
        vis[v] = 1;
        dfs(v);
        sum += ((ll)num[v] * (n - num[v]))*edge0[u][i].v;
        num[u] += num[v];
    }
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        for(int i = 1; i <= n; i++) edge0[i].clear();
        for(int i = 1; i <= m; i++){
            scanf("%d%d%d",&edge[i].from,&edge[i].to,&edge[i].v);
        }
        printf("%lld ",kruskal());
        for(int i = 1; i <= n; i++) num[i] = 1;
        CLR(vis,0);
        sum = 0;
        dfs(1);
        printf("%.2f\n",(1.0*sum)/(((ll)n*(n-1)/2.0)));
    }
    return 0;
}

转载于:https://www.cnblogs.com/Tokisaki-Kurumi-/p/9389173.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
代码下载:完整代码,可直接运行 ;运行版本:2022a或2019b或2014a;若运行有问题,可私信博主; **仿真咨询 1 各类智能优化算法改进及应用** 生产调度、经济调度、装配线调度、充电优化、车间调度、发车优化、水库调度、三维装箱、物流选址、货位优化、公交排班优化、充电桩布局优化、车间布局优化、集装箱船配载优化、水泵组合优化、解医疗资源分配优化、设施布局优化、可视域基站和无人机选址优化 **2 机器学习和深度学习方面** 卷积神经网络(CNN)、LSTM、支持向量机(SVM)、最小二乘支持向量机(LSSVM)、极限学习机(ELM)、核极限学习机(KELM)、BP、RBF、宽度学习、DBN、RF、RBF、DELM、XGBOOST、TCN实现风电预测、光伏预测、电池寿命预测、辐射源识别、交通流预测、负荷预测、股价预测、PM2.5浓度预测、电池健康状态预测、水体光学参数反演、NLOS信号识别、地铁停车精准预测、变压器故障诊断 **3 图像处理方面** 图像识别、图像分割、图像检测、图像隐藏、图像配准、图像拼接、图像融合、图像增强、图像压缩感知 **4 路径规划方面** 旅行商问题(TSP)、车辆路径问题(VRP、MVRP、CVRP、VRPTW等)、无人机三维路径规划、无人机协同、无人机编队、机器人路径规划、栅格地图路径规划、多式联运运输问题、车辆协同无人机路径规划、天线线性阵列分布优化、车间布局优化 **5 无人机应用方面** 无人机路径规划、无人机控制、无人机编队、无人机协同、无人机任务分配 **6 无线传感器定位及布局方面** 传感器部署优化、通信协议优化、路由优化、目标定位优化、Dv-Hop定位优化、Leach协议优化、WSN覆盖优化、组播优化、RSSI定位优化 **7 信号处理方面** 信号识别、信号加密、信号去噪、信号增强、雷达信号处理、信号水印嵌入提取、肌电信号、脑电信号、信号配时优化 **8 电力系统方面** 微电网优化、无功优化、配电网重构、储能配置 **9 元胞自动机方面** 交通流 人群疏散 病毒扩散 晶体生长 **10 雷达方面** 卡尔曼滤波跟踪、航迹关联、航迹融合

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值