Sum of the Line(ICPC2017 Urumqi)

题目描述
Consider a triangle of integers, denoted by T. The value at (r, c) is denoted by Tr,c , where 1 ≤ r and 1 ≤ c ≤ r. If the greatest common divisor of r and c is exactly 1, Tr,c = c, or 0 otherwise.
Now, we have another triangle of integers, denoted by S. The value at (r, c) is denoted by S r,c , where 1 ≤ r and 1 ≤ c ≤ r. S r,c is defined as the summation    
Here comes your turn. For given positive integer k, you need to calculate the summation of elements in k-th row of the triangle S.
输入
The first line of input contains an integer t (1 ≤ t ≤ 10000) which is the number of test cases.
Each test case includes a single line with an integer k described as above satisfying 2 ≤ k ≤ 10^8 .
输出
For each case, calculate the summation of elements in the k-th row of S, and output the remainder when it divided
by 998244353.
样例输入
2
2
3
样例输出
1
5


题意:对于gcd(i,k) == 1,则S(i,k) = i,否则为0,求S = sigma(S(i,k)^2)

题解:
如果没有gcd(i,k)这个限制,则答案就为signa(i^2) 即sigma(i^2) = n*(n+1)*(2*n+1)/6
gcd(i,k) != 1,说明i 与 k 存在共同的因子(除1外),对于n(<=1e8)的最多的素因子不超过10个,对因子进行容斥
可以表示为:|U| - |A∪B∪C∪....∪Z| ,A ,B ,...., Z 分别表示为能被某个素数整除的

首先将k中素因子筛选出来,用唯一分解定理,然后对这些因子进行容斥,可以dfs,也可以用二进制 (0,1表示取或不取,但必须保证至少取一次)

AC code:
#include <iostream>
#include <cstdio>
using namespace std;
const int MAXN = 10000000;
const int mod = 998244353;
typedef long long ll;

ll fast_pow(ll a,ll n)
{
    ll ans = 1;
    while(n)
    {
        if(n&1) ans = (ans * a)%mod;
        a = (a * a)%mod;
        n >>= 1;
    }
    return ans;
}
const ll six = fast_pow(6,mod-2);

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int tot = 0;
        ll n,k;
        scanf("%lld",&k);
        n = k;
        int prime[100];
        for(int i = 2;i * i <= n;i++)
        {
            if(n % i == 0)
            {
                prime[tot++] = i;
                while(n % i == 0)   n /= i;
            }
        }
        if(n != 1) prime[tot++] = n;
        ll ans = k*(k+1)%mod*(2*k+1)%mod*six%mod;
        for(int i = 1;i < (1<<tot);i++)
        {
            n = i;
            int pos = tot - 1,cnt = 0;
            ll ant = 1;
            while(n)
            {
                if(n&1) ant *= prime[pos],cnt++;
                pos--;
                n >>= 1;
            }
            ll m = k/ant;
            if(cnt&1)
                ans = (ans - ant*ant%mod*m%mod*(m + 1)%mod*(2*m + 1)%mod*six%mod + mod)%mod;
            else
                ans = (ans + ant*ant%mod*m%mod*(m + 1)%mod*(2*m + 1)%mod*six%mod)%mod;
        }
        printf("%lld\n",ans);
    }
}

 






转载于:https://www.cnblogs.com/lemon-jade/p/9515875.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值