Milking Order

问题 C: Milking Order

时间限制: 3 Sec   内存限制: 128 MB
提交: 20   解决: 7
[ 提交] [ 状态] [ 讨论版] [命题人: ]
题目描述
Farmer John's N cows (1≤N≤105), numbered 1…N as always, happen to have too much time on their hooves. As a result, they have worked out a complex social hierarchy related to the order in which Farmer John milks them every morning.
After weeks of study, Farmer John has made M observations about his cows' social structure (1≤M≤50,000). Each observation is an ordered list of some of his cows, indicating that these cows should be milked in the same order in which they appear in this list. For example, if one of Farmer John's observations is the list 2, 5, 1, Farmer John should milk cow 2 sometime before he milks cow 5, who should be milked sometime before he milks cow 1.

Farmer John's observations are prioritized, so his goal is to maximize the value of X for which his milking order meets the conditions outlined in the first X observations. If multiple milking orders satisfy these first X conditions, Farmer John believes that it is a longstanding tradition that cows with lower numbers outrank those with higher numbers, so he would like to milk the lowest-numbered cows first. More formally, if multiple milking orders satisfy these conditions, Farmer John would like to use the lexicographically smallest one. An ordering x is lexicographically smaller than an ordering y if for some j, xi=yi for all i<j and xj<yj (in other words, the two orderings are identical up to a certain point, at which x is smaller than yy).

Please help Farmer John determine the best order in which to milk his cows.

输入
The first line contains N and M. The next M lines each describe an observation. Line i+1 describes observation i, and starts with the number of cows mi listed in the observation followed by the list of mimi integers giving the ordering of cows in the observation. The sum of the mi's is at most 200,000.

输出
Output N space-separated integers, giving a permutation of 1…N containing the order in which Farmer John should milk his cows.

样例输入
4 3
3 1 2 3
2 4 2
3 3 4 1

样例输出
1 4 2 3

提示

Here, Farmer John has four cows and should milk cow 1 before cow 2 and cow 2 before cow 3 (the first observation), cow 4 before cow 2 (the second observation), and cow 3 before cow 4 and cow 4 before cow 1 (the third observation). The first two observations can be satisfied simultaneously, but Farmer John cannot meet all of these criteria at once, as to do so would require that cow 1 come before cow 3 and cow 3 before cow 1.

This means there are two possible orderings: 1 4 2 3 and 4 1 2 3, the first being lexicographically smaller.

#include <iostream>
#include <string>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
#include <deque>
#include <map>
#define range(i,a,b) for(int i=a;i<=b;++i)
#define LL long long
#define rerange(i,a,b) for(int i=a;i>=b;--i)
#define fill(arr,tmp) memset(arr,tmp,sizeof(arr))
using namespace std;
const int N=(int)5e5+5;
int front[N],to[N<<1],link[N<<1],r[N],cnt,n,m;
bool vis[N];
vector<int>MAP[N];
struct node{
    int id;
    node(int tmp){id=tmp;}
    bool operator <(const node&a)const{
        return a.id<id;
    }
};
priority_queue<node>dd;
void init(){
    cin>>n>>m;
    range(i,1,m){
        int s,e;
        cin>>s;
        range(j,1,s){
            cin>>e;
            MAP[i].push_back(e);
        }
    }
}
void add_edge(int x,int y){
    ++cnt;
    to[cnt]=y;
    link[cnt]=front[x];
    front[x]=cnt;
}
void build_tree(int mid){
    cnt=0;
    fill(front,0);fill(r,0);fill(vis,0);
    range(i,1,mid)
    range(j,0,MAP[i].size()-2) {
        add_edge(MAP[i][j], MAP[i][j + 1]);
        ++r[MAP[i][j+1]];
    }
}
bool tsort(int x){
    int sum=0;
    range(i,1,n)if(!r[i])++sum,dd.push(node(i)),vis[i]=1;
    while(!dd.empty()){
        node head=dd.top();
        if(x)cout<<head.id<<" ";
        dd.pop();
        for(int i=front[head.id];i;i=link[i]){
            --r[to[i]];
            if(!r[to[i]]&&!vis[to[i]])dd.push(node(to[i])),++sum,vis[to[i]]=true;
        }
    }
    return sum==n;
}
void solve(){
    int left=0,right=m+1,ans;
    while(left<=right){
        int mid=((left+right)>>1);
        build_tree(mid);
        if(tsort(0))left=mid+1,ans=mid;
        else right=mid-1;
    }
    build_tree(ans);
    tsort(1);
}
int main() {
    init();
    solve();
    return 0;
}
View Code

 


 

转载于:https://www.cnblogs.com/Rhythm-/p/9350236.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Based on the following story, continue the story by writing two paragraphs, paragraph 1 beginning with "A few weeks later, I went to the farm again. " and paragraph 2 beginning with "I was just about to leave when the hummingbird appeared."respectively with 150 words. I was invited to a cookout on an old friend's farm in western Washington. I parked my car outside the farm and walked past a milking house which had apparently not been used in many years.A noise at a window caught my attention,so I entered it. It was a hummingbird,desperately trying to escape. She was covered in spider-webs and was barely able to move her wings. She ceased her struggle the instant I picked her up. With the bird in my cupped hand, I looked around to see how she had gotten in. The broken window glass was the likely answer. I stuffed a piece of cloth into the hole and took her outside,closing the door securely behind me. When I opened my hand, the bird did not fly away; she sat looking at me with her bright eyes.I removed the sticky spider-webs that covered her head and wings. Still, she made no attempt to fly.Perhaps she had been struggling against the window too long and was too tired? Or too thirsty? As I carried her up the blackberry-lined path toward my car where I kept a water bottle, she began to move. I stopped, and she soon took wing but did not immediately fly away. Hovering,she approached within six inches of my face. For a very long moment,this tiny creature looked into my eyes, turning her head from side to side. Then she flew quickly out of sight. During the cookout, I told my hosts about the hummingbird incident. They promised to fix the window. As I was departing, my friends walked me to my car. I was standing by the car when a hummingbird flew to the center of our group and began hovering. She turned from person to person until she came to me. She again looked directly into my eyes, then let out a squeaking call and was gone. For a moment, all were speechless. Then someone said, “She must have come to say good-bye.”
02-12

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值