POJ 1286 Necklace of Beads(项链的珠子)

Necklace of Beads
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 7874 Accepted: 3290

Description

Beads of red, blue or green colors are connected together into a circular necklace of n beads ( n < 24 ). If the repetitions that are produced by rotation around the center of the circular necklace or reflection to the axis of symmetry are all neglected, how many different forms of the necklace are there? 

Input

The input has several lines, and each line contains the input data n. 
-1 denotes the end of the input file. 

Output

The output should contain the output data: Number of different forms, in each line correspondent to the input data.

Sample Input

4
5
-1

Sample Output

21
39

/*Polya原理*/
#include <cstdio>
#include <iostream>
using namespace std;
long long aaaa(long long a,long long b)
{
    long long res=1,tmp=a;
    while(b) 
    {
        if (b&1) 
            res*=tmp;
        tmp*=tmp;
        b>>=1;
    }
    return res;
}
int gcd(int a,int b) 
{
    return b==0?a:gcd(b,a%b);
}
int main()
{
    int n;
    while ( ~scanf("%d", &n) && n != -1) 
    {
        long long a = 0, b = 0;
        for (int i=0;i<n;i++) 
        {
            a+=aaaa(3,gcd(i,n));
        } 
        if (n&1) 
            b=(long long)n*aaaa(3,(n+1)/2);
        else 
            b=(long long)n/2*(aaaa(3,n/2+1)+aaaa(3,n/2));
        if (n==0) 
            printf("0\n");
        else 
            printf("%lld\n",(a+b)/2/n);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/xiaoqi7/p/5903207.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值