hdu1796(二进制枚举)

Problem Description
  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
 

Input
  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
 

Output
  For each case, output the number.
 

Sample Input
 
  
12 2 2 3
 

Sample Output
 
  
7

典型的二进制枚举的题,数据开的不大,所以容易二进制枚举很容易做到!这题有点坑的地方在于the M integer are non-negative and won’t exceed 20.是说的非负数,也就是说可能会有0出现,这个条件没看到刚开始死活不a啊,思考数据方面的能力真的很需要加强啊哭

其次这个题还是典型的容斥原理!本是水题一道,唉。。。。

#include <iostream>
#include <stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
typedef long long ll;
ll gcd(ll a,ll b)
{
    return b?gcd(b,a%b):a;
}
ll lcm(ll a,ll b)
{
    return a/gcd(a,b)*b;
}
int main()
{
    int n,m;ll a[30];
    ll b;
    while(~scanf("%d%d",&n,&m))
    {
        n--;int k=m+1;
        for(int i=0;i<m;i++)
            {
                scanf("%lld",&a[i]);if(a[i]==0)k=i;
            }
            if(k!=m+1)
            {
                m--;swap(a[k],a[m]);
            }
        ll s=0;
        for(ll i=1;i<1<<m;i++)
        {
            b=1;
            ll t=i,num=0,nn=0,flag=0;
            while(1)
            {
                int x=t%2;
                if(x)
                {
                    b=lcm(b,a[num]);nn++;
                }
                t/=2;if(t==0)break;
                num++;
            }
            if(nn&1)
            s+=n/b;
            else
            s-=n/b;
        }printf("%d\n",s);
    }
    return 0;
}




转载于:https://www.cnblogs.com/martinue/p/5490511.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值