POJ 1128 Frame Stacking (拓扑排序)

题目链接

Description
Consider the following 5 picture frames placed on an 9 x 8 array.

........ ........ ........ ........ .CCC....
EEEEEE.. ........ ........ ..BBBB.. .C.C....
E....E.. DDDDDD.. ........ ..B..B.. .C.C....
E....E.. D....D.. ........ ..B..B.. .CCC....
E....E.. D....D.. ....AAAA ..B..B.. ........
E....E.. D....D.. ....A..A ..BBBB.. ........
E....E.. DDDDDD.. ....A..A ........ ........
E....E.. ........ ....AAAA ........ ........
EEEEEE.. ........ ........ ........ ........
1 2 3 4 5

Now place them on top of one another starting with 1 at the bottom and ending up with 5 on top. If any part of a frame covers another it hides that part of the frame below.

Viewing the stack of 5 frames we see the following.

.CCC....
ECBCBB..
DCBCDB..
DCCC.B..
D.B.ABAA
D.BBBB.A
DDDDAD.A
E...AAAA
EEEEEE..

In what order are the frames stacked from bottom to top? The answer is EDABC.

Your problem is to determine the order in which the frames are stacked from bottom to top given a picture of the stacked frames. Here are the rules:

  1. The width of the frame is always exactly 1 character and the sides are never shorter than 3 characters.

  2. It is possible to see at least one part of each of the four sides of a frame. A corner shows two sides.

  3. The frames will be lettered with capital letters, and no two frames will be assigned the same letter.

Input
Each input block contains the height, h (h<=30) on the first line and the width w (w<=30) on the second. A picture of the stacked frames is then given as h strings with w characters each.
Your input may contain multiple blocks of the format described above, without any blank lines in between. All blocks in the input must be processed sequentially.

Output
Write the solution to the standard output. Give the letters of the frames in the order they were stacked from bottom to top. If there are multiple possibilities for an ordering, list all such possibilities in alphabetical order, each one on a separate line. There will always be at least one legal ordering for each input block. List the output for all blocks in the input sequentially, without any blank lines (not even between blocks).

Sample Input
9 8
.CCC....
ECBCBB..
DCBCDB..
DCCC.B..
D.B.ABAA
D.BBBB.A
DDDDAD.A
E...AAAA
EEEEEE..

Sample Output
EDABC

题意:
给定几张n*m的图片,每个图片上对应有一个特定的字母,将这些图片叠放在一起,并且对应位置显示的是最上面那个图片上的字母(当然有的位置可能没有字母,这样的话就不用考虑),给出堆叠后的字母显示情况,要求输出所有可能的从下到上的图片的堆叠情况。

分析:
1.题目已经很明确的告诉每个边框的每条边,至少会有一个字母露在外面所以遍历整张图,确定每个边框的范围。 只需确定左上角和右下角即可。
2.根据每个边框的范围再遍历,若应该出现A的位置出现了B,那么B一定在A上面。这样各个边框的上下顺序就求出来。
若B在A上面,那么记录A->B。
3.拓扑排序
4.要求输出所有能情况且按字母顺序输出。那么只要按照字母顺序使用DFS(递归)来解决,注意处理完入度为0的点(删边更新入度),递归进去后要还原回来(删去的边弄回来,入度更新回来)。从而保证可以下次使用

代码:

#include <iostream>
#include <cstring>
#include <iterator>
#include <vector>
#include <cstdio>
using namespace std;
struct Frame
{
    int x1, y1;//左上角
    int x2, y2;//右下角
    //左上角必须初始化大一点,右下角必须初始化小一点
    Frame()
    {
        x1 = y1 = 100;
        x2 = y2 = -100;
    }
};
//记录26个字母使用了哪些
bool used[26];
//入度
int into[26];
//存储拓扑排序的图,但是要明白的一点就是拓扑排序的图和原图在意义上的差别是很大的,表示的是第i个字母的边框又有没有被第j个字母覆盖
int map[26][26];
//输入的原始图
char matrix[32][32];
vector<char> ans;
//建立拓扑排序的图 即更新into数组
void buildMap(Frame frame[])
{
    for (int i = 0; i < 26; ++i)
    {
        //若此字母用过,即这个字母曾经出现过
        if (used[i])
        {
            //遍历frame第一列和最后一列
            for (int j = frame[i].x1; j <= frame[i].x2; ++j)
            {
                if (matrix[j][frame[i].y1] != i+'A')//在这之间出现了其他的字符
                {
                    //要加这个判断条件,不然入度会被多算 如CBBC 则B的入度被算成了2其实是1
                    if (map[i][matrix[j][frame[i].y1]-'A'] == 0)//第i个字母的边框里有没有出现第matrix[j][frame[i].y1]-'A'个字母
                    {
                        //记录入度
                        into[matrix[j][frame[i].y1]-'A']++;
                        //建图
                        map[i][matrix[j][frame[i].y1]-'A'] = 1;//标记出现过
                    }
                }
                if (matrix[j][frame[i].y2] != i+'A')
                {
                    if (map[i][matrix[j][frame[i].y2]-'A'] == 0)
                    {
                        into[matrix[j][frame[i].y2]-'A']++;

                        map[i][matrix[j][frame[i].y2]-'A'] = 1;
                    }
                }
            }
            //遍历frame第一行和最后一行
            for (int j = frame[i].y1; j <= frame[i].y2; ++j)
            {
                if (matrix[frame[i].x1][j] != i+'A')
                {
                    if (map[i][matrix[frame[i].x1][j]-'A'] == 0)
                    {
                        into[matrix[frame[i].x1][j]-'A']++;
                        map[i][matrix[frame[i].x1][j]-'A'] = 1;
                    }
                }
                if (matrix[frame[i].x2][j] != i+'A')
                {
                    if (map[i][matrix[frame[i].x2][j]-'A'] == 0)
                    {
                        into[matrix[frame[i].x2][j]-'A']++;
                        map[i][matrix[frame[i].x2][j]-'A'] = 1;
                    }
                }
            }
        }
    }
}

//depth用于判断递归了多少次
void topo(int depth, int count)//拓扑排序的核心代码
{
    //若递归的次数大于或等于所用字母的次数则可以结束
    if (depth >= count)
    {
        vector<char>::iterator  it;
        for(it=ans.begin();it!=ans.end();it++)
            cout<<*it;
        cout << endl;
        return;
    }
    for (int i = 0; i < 26; ++i)
    {
        if (used[i])
        {
            if (into[i] == 0)
            {
                //删除入度为0的点所发出的边
                ans.push_back(i+'A');
                into[i] = -1;
                for (int k = 0; k < 26; ++k)
                {
                    if (map[i][k] == 1)
                    {
                        into[k]--;
                    }
                }
                topo(depth+1, count);
                //还原
                ans.pop_back();
                into[i] = 0;
                for (int k = 0; k < 26; ++k)
                {
                    if (map[i][k] == 1)
                    {
                        into[k]++;
                    }
                }
            }
        }
    }
}
int main()
{
    int n, m;
    while (scanf("%d",&n) != EOF)
    {
        cin >> m;
        memset(used, 0, sizeof(used));
        memset(into, 0, sizeof(into));
        memset(map, 0, sizeof(map));
        memset(matrix, 0, sizeof(matrix));
        Frame frame[26];
        ans.clear();
        string temp;
        for (int i = 0; i < n; ++i)
        {
            cin >> temp;
            for (int j = 0; j < m; ++j)
            {
                matrix[i][j] = temp[j];
                if (matrix[i][j] != '.')
                {
                    int toNum = matrix[i][j]-'A';
                    used[toNum] = true;
                    //更新左上角和右下角,一个字母出现的最左上和最右下的位置
                    if (frame[toNum].x1 > i) frame[toNum].x1 = i;
                    if (frame[toNum].y1 > j) frame[toNum].y1 = j;
                    if (frame[toNum].x2 < i) frame[toNum].x2 = i;
                    if (frame[toNum].y2 < j) frame[toNum].y2 = j;
                }
            }
        }
        buildMap(frame);
        //一共用了多少个字母
        int count = 0;
        for (int i = 0; i < 26; ++i)
            if (used[i])
                count++;
        topo(0, count);
    }
}

转载于:https://www.cnblogs.com/cmmdc/p/7698848.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值