hdu5417(BC)

题目链接:点这儿

Victor and Machine

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 87    Accepted Submission(s): 48


Problem Description
Victor has a machine. When the machine starts up, it will pop out a ball immediately. After that, the machine will pop out a ball every  w seconds. However, the machine has some flaws, every time after  x seconds of process the machine has to turn off for  y seconds for maintenance work. At the second the machine will be shut down, it may pop out a ball. And while it's off, the machine will pop out no ball before the machine restart.

Now, at the  0 second, the machine opens for the first time. Victor wants to know when the  n-th ball will be popped out. Could you tell him?
 

Input
The input contains several test cases, at most  100 cases.

Each line has four integers  x y w and  n. Their meanings are shown above。



1x,y,w,n100.

 

Output
For each test case, you should output a line contains a number indicates the time when the  n-th ball will be popped out.
 

Sample Input
 
      
2 3 3 3 98 76 54 32 10 9 8 100
 

Sample Output
 
      
10 2664 939
 

Source


题意:有中文版的。就不多说了

分析:机器执行关闭为一回合。计算出每回合能弹出多少个小球。然后处理一下不是执行/关闭的情况就OK了。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
#define ll long long
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;

int main ()
{
    int x,y,w,n;
    while (scanf ("%d%d%d%d",&x,&y,&w,&n)==4)
    {
        int t;
        if (x < w)
            t = (x+y)*(n-1);
        else
        {
            int a=x/w+1;
            if (n%a==0)
                t = (n/a)*(x+y)-y-x%w;
            else
                t = (n/a)*(x+y)+(n%a-1)*w;
        }
        printf ("%d\n",t);
    }
    return 0;
}


posted on 2017-07-26 11:41 mthoutai 阅读( ...) 评论( ...) 编辑 收藏

转载于:https://www.cnblogs.com/mthoutai/p/7238792.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值