Flesch Reading Ease -POJ3371模拟

Flesch Reading Ease

Description

Flesch Reading Ease, a readability test named after its deviser Rudolf Flesch, is among most ubiquitously used readability tests, which are principally employed for assessment of the difficulty to understand a reading passage written in English. The Flesch Reading Ease score of a passage relies solely on three statistics, namely the total numbers of sentences, words and syllables, of the passage. Specifically, the score is defined by the following formula:

.这里写图片描述

As can be inferred from the above formula, a passage with a high Flesch Reading Ease score tends to favor shorter sentences and words, which is in compliance with commonsense in spite of partial accuracy. (Think of, for instance, the word “television”. Long as it may seem, it is indeed one of the first words that any individual who studies English learns.) A related Wikipedia entry on Flesch Reading Ease [1] suggests that passages scoring 90~100 are comprehensible for an average American 5th grader, and 8th and 9th graders possess the ability to follow passages with a score in the range of 60~70, whereas passages not exceeding 30 in the score are best suitable for college graduates. The text of this problem, all sections taken into account, scores roughly 50 as per the calculation of Google Documents.

Despite the simplicity in its ideas, several aspects of its definition remains vague for any real-world implementation of Flesch Reading Ease. For the sake of precision and uniformity, the following restrictions adapted from [2] are adopted for this problem, to which you are to write a solution that effectively computes the Flesch Reading Ease score of a given passage of English text.

  1. Periods, explanation points, colons and semicolons serve as sentence delimiters.
  2. Each group of continuous non-blank characters with beginning and ending punctuation removed counts as a word.
  3. Each vowel (one of a, e, i, o, u and y) in a word is considered one syllable subject to that
    • -es, -ed and -e (except -le) endings are ignored,
    • words of three letters or shorter count as single syllables,
    • consecutive vowels count as one syllable.

References

  1. Wikipedia contributors. Flesch-Kincaid Readability Test. Wikipedia, The Free Encyclopedia. August 30, 2007, 01:57 UTC. Available at:http://en.wikipedia.org/w/index.php?title=Flesch-Kincaid_Readability_Test&oldid=154509512. Accessed September 5, 2007.
  2. Talburt, J. 1985. The Flesch index: An easily programmable readability analysis algorithm. In Proceedings of the 4th Annual international Conference on Systems Documentation. SIGDOC ‘85. ACM Press, New York, NY, 114-122.

Input

The input contains a passage in English whose Flesch Reading Ease score is to be computed. Only letters of the English alphabet (both lowercase and uppercase), common punctuation marks (periods, question and exclamation marks, colons, semicolons as well as commas, quotation marks, hyphens and apostrophes), and spaces appear in the passage. The passage is of indefinite length and possibly occupies multiple lines. Additionally, it is guaranteed to be correct in punctuation.

Output

Output the Flesch Reading Ease score of the given passage rounded to two digits beyond decimal point.

Sample Input

Flesch Reading Ease, a readability test named after its deviser Rudolf Flesch,
is among most ubiquitously used readability tests, which are principally
employed for assessment of the difficulty to understand a reading passage
written in English. The Flesch Reading Ease score of a passage relies solely
on three statistics, namely the total numbers of sentences, words and
syllables, of the passage.

Sample Output

26.09

Source

POJ Monthly–2007.09.09, frkstyc

题意:标记单词分隔符: 逗号(,) 和 空格( )句子分隔符:句号(.) 问号(?) 冒号(:) 分号(;) 感叹号(!).不存在上述标点符号以外的符号!!!所有符号只占一个字符的位置!!

每出现一个单词分隔符,单词数+1
每出现一个句子分隔符,句子数+1
音节数是最难处理的,其规律如下:

(1)当单词总长度<=3时,音节数无条件+1
(2)当单词总长度>3时,单词中每出现一个元音字母(a、e、i、o、u、y),音节数+1,但是连续的元音字母只按1个音节计算,且当单词后缀为-es、-ed和-e时,后缀的元音字母e不列为音节数计算。但是后缀-le例外,要计算音节数。

注意:
(1)元音字母要判断12个,6个小写,6个大写。

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <vector>
#include <algorithm>
#define RR() freopen("in.txt","r",stdin)

using namespace std;

char str[110];

bool Judgeapl(char s)//判断是否时字母
{
    if(s>='a'&&s<='z'||s>='A'&&s<='Z')
    {
        return true;
    }
    return false;
}

bool Trans(char s)//判断是否是元音
{
    if(s>='A'&&s<='Z')
    {
        s=s-'A'+'a';
    }
    if(s=='a'||s=='e'||s=='i'||s=='o'||s=='u'||s=='y')
    {
        return true;
    }
    return false;
}

char low(char s)//大写转小写
{
    if(s>='A'&&s<='Z')
    {
        return s-'A'+'a';
    }
    return s;
}

int Judgesyl(char *s,int len)//判断元音节
{
    if(len<=3)
    {
        return 1;
    }

    int num  = 0;

    int ans = 0;

    for(int i=0; i<len; i++)
    {
        if(Trans(str[i]))
        {
            ans=0;

            while(Trans(str[i])&&i<len)
            {
                i++;
                ans++;
            }
            i--;
            num++;
        }
    }
    if(low(s[len-1])=='e'&&low(s[len-2])!='l'&&!Trans(s[len-2]))
    {
        num--;
    }
    else if(low(s[len-2]) == 'e' &&(low(s[len-1]=='s'||low(s[len-1])=='d'))&&!Trans(s[len-3]))
    {
        num--;
    }
    return num;
}

int main()
{
    int wnum=0,snum=0,senum=0;
    while(~scanf("%s",str))
    {

        int len=strlen(str);
        wnum++;
        if(!Judgeapl(str[len-1]))
        {
            if(str[len-1]!=',')
                senum++;
            len--;
        }

        snum+=Judgesyl(str,len);

    }
    printf("%.2f\n",206.835-1.015*(wnum*1.0/senum)-84.6*(snum*1.0/wnum));
    return 0;
}

转载于:https://www.cnblogs.com/juechen/p/5255877.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值