ACM寻找连续的数的乘积最大值

Given a sequence of integers S = {S1, S2, . . . , Sn}, you should determine what is the value of the maximum positive product involving consecutive terms of S. If you cannot find a positive sequence, you should consider 0 as the value of the maximum product.

Input

Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si is an integer such that −10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each element in the sequence. There is a blank line after each test case. The input is terminated by end of file (EOF).

Output

For each test case you must print the message: ‘Case #M: The maximum product is P.’, where M is the number of the test case, starting from 1, and P is the value of the maximum product. After each test case you must print a blank line.

Sample Input 3 2 4 -3 5 2 5 -1 2 -1

Sample Output

Case #1:The maximum product is 8.

Case #2: The maximum product is 20.

解题思路:这个题目的大意是让我们寻找连续的数的乘积的最大值。我们用两个for循环就解决掉了这两个问题,然后比较得出最大的乘积数。

程序代码:

#include <iostream>
using namespace std;
int a[22];
int main()
{
    int n,v=0;
    long t;
    while(cin>>n&&n)
    {
        v++;
        long min=0;
        for(int i=0;i<n;i++)
            cin>>a[i];
        for(int k=0;k<n;k++)
        {
            t=1;
            for(int j=k;j<n;j++)
            {
                t=t*a[j];
                if(t>min)
                    min=t;
            }
        }
        cout<<"Case #"<<v<<": The maximum product is "<<min<<"."<<endl<<endl;

    }
    return 0;

}

 

转载于:https://www.cnblogs.com/xinxiangqing/p/4688350.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值