HDU 2139 Calculate the formula

http://acm.hdu.edu.cn/showproblem.php?pid=2139

 

Problem Description
You just need to calculate the sum of the formula: 1^2+3^2+5^2+……+ n ^2.
 
Input
In each case, there is an odd positive integer n.
 
Output
Print the sum. Make sure the sum will not exceed 2^31-1
 
Sample Input
3
 
Sample Output
10
 

 代码:

#include <bits/stdc++.h>
using namespace std;

const int maxn = 2345;
long long s[maxn];

int main() {
    int N;
    s[1] = 1;
    for(int i = 3; i <= maxn; i += 2)
        s[i] = s[i - 2] + i * i;

    while(~scanf("%d", &N)) {
        printf("%lld\n", s[N]);
    }

    return 0;
}

  

转载于:https://www.cnblogs.com/zlrrrr/p/9686151.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值