ACM最大公共子序列&&回文串

---恢复内容开始---

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2
解题思路:
题目大意是这样的,我们输入一个整数n和一个字符串,取这个字符串的前n位,然后问我们需要改变几个字符可以使这个字符串变成一个回文字符串。我们将这个字符串存在a数组中,然后将这个字符的逆序存在b数组中,这样我们就得到了两个数组,我们可以把这个题目转化为一个求最大公共子序列的问题了,我们求出这两个数组的最大公共子序列,然后将这个数组的长度减去这个最大公共子序列的长度,就得到了我们需要改变的字符个数。这是这种题目解题的一贯思路回文+最大公共子序列
程序代码:
#include <iostream>
using namespace std;
const int N=5005;
char a[N],b[N];
short save[N][N];
int n;
int max(int x,int y)
{
	return x>y?x:y;
}
int maxlen(char *str1,char *str2)
{
	int i,j;
    for(i=0;i<=n;i++)
        save[i][0]=save[0][i]=0;
    for(i=1;i<=n;i++)
        for(j=1;j<=n;j++)   //以下从str1[0]和str2[0]开始比较
            save[i][j]=(str1[i-1]==str2[j-1] ? save[i-1][j-1]+1 : max(save[i-1][j],save[i][j-1]));
    return save[n][n];
}
int main()
{
	cin>>n;
	scanf("%s",a);
	for(int i=0;i<n;i++)
		b[n-i-1]=a[i];
	b[n]='\0';
	cout<<n-maxlen(a,b)<<endl;
	return 0;
}
 
   

  



---恢复内容结束---

转载于:https://www.cnblogs.com/xinxiangqing/p/4730979.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值