每日一九度之 题目1031:xxx定律

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:6870

解决:4302

题目描述:
    对于一个数n,如果是偶数,就把n砍掉一半;如果是奇数,把n变成 3*n+ 1后砍掉一半,直到该数变为1为止。
    请计算需要经过几步才能将n变到1,具体可见样例。
输入:
    测试包含多个用例,每个用例包含一个整数n,当n为0 时表示输入结束。(1<=n<=10000)
输出:
    对于每组测试用例请输出一个数,表示需要经过的步数,每组输出占一行。
样例输入:
3
1
0
样例输出:
5
0

挺简单的一道模拟题,但是也可以用数学方法计算出n与次数的关系式(可以自己尝试下)。

//Asimple
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cctype>
#include <cstdlib>
#include <stack>
#include <cmath>
#include <map>
#include <string>
#include <queue>
#define INF 100000
using namespace std;
const int maxn = 1005;
typedef long long ll;
int n;

int fun(int n, int cnt){
    if( n == 1 ) return cnt;
    else if( n & 1 ){
        n = 3 * n + 1 ;
        n /= 2 ;
        fun(n,cnt+1);
    } else {
        n /= 2 ;
        fun(n,cnt+1);
    }
}

int main(){
    while( scanf("%d",&n) && n ){
        int cnt = 0;
        cout << fun(n,cnt) << endl ;
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/Asimple/p/5865469.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值