1116. Come on! Let's C (20)

1116. Come on! Let's C (20)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

"Let's C" is a popular and fun programming contest hosted by the College of Computer Science and Technology, Zhejiang University. Since the idea of the contest is for fun, the award rules are funny as the following:

0. The Champion will receive a "Mystery Award" (such as a BIG collection of students' research papers...).
1. Those who ranked as a prime number will receive the best award -- the Minions (小黄人)!
2. Everyone else will receive chocolates.

Given the final ranklist and a sequence of contestant ID's, you are supposed to tell the corresponding awards.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=10000), the total number of contestants. Then N lines of the ranklist follow, each in order gives a contestant's ID (a 4-digit number). After the ranklist, there is a positive integer K followed by K query ID's.

Output Specification:

For each query, print in a line "ID: award" where the award is "Mystery Award", or "Minion", or "Chocolate". If the ID is not in the ranklist, print "Are you kidding?" instead. If the ID has been checked before, print "ID: Checked".

Sample Input:
6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222
Sample Output:
8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?


题意:给出含有n个数据的获奖名单,再给出含有k个数据的询问列表,输出它们的获奖情况

分析:阅读理解题,通过本题我们学会了prime和champion,快拿小本本记下来

           prime 素数名次的获得小黄人大奖(banana)

           champion 冠军获得神秘奖

           不在获奖名单内的输出 巴拉巴拉

           已经询问过的输出 巴拉

           剩下的 获得巧克力

           一般这个不会直接拿来暴力搜,那个数组直接带进去比较好,因为10000也不算大,另外注意初始-1

代码:

#include<cstdio>
#include<cstring>
using namespace std;
int num[10002];
int prime(int n){
	for(int i=2;i<n/2;i++)
		if(!(n%i)) return 0;
	return 1;
}
int main()
{
	int n,k,tmp;
	scanf("%d",&n);
	memset(num,-1,sizeof(int)*10002);
	for(int i=1;i<=n;i++){
		scanf("%d",&tmp);
		num[tmp]=i;
	}
	scanf("%d",&k);
	for(int i=0;i<k;i++)
	{
		scanf("%d",&tmp);
		if(num[tmp]==1) {
			printf("%04d: Mystery Award\n",tmp);
			num[tmp]=-2;
		} 
		else if(num[tmp]==-1)
			printf("%04d: Are you kidding?\n",tmp);
		else if(num[tmp]==-2)
			printf("%04d: Checked\n",tmp);
		else if(prime(num[tmp])) {
			printf("%04d: Minion\n",tmp);
			num[tmp]=-2;
		}
		else {
			printf("%04d: Chocolate\n",tmp);
			num[tmp]=-2;
		}
	}	
}




转载于:https://www.cnblogs.com/childwang/p/8280266.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值